Jump to content

Recommended Posts

2007 "newer style" Regular Cab W/T model truck.

 

 

Ok I have been in the process of deciding on a GPS unit, I was going to buy a portable Garmin so I could take it anywhere (I own 2 vehicles).

 

Anyways, I have decided to go with a stereo head unit with a GPS built in for my truck. My car is a work beater and my cellphone will do for the rare time I need to go somewhere other than work in it.

 

I was going to go with a kenwood 9990HD but it doesn't have a 3.5mm aux jack so I can use my SIRIUS PLUG AND PLAY DOCK. I won't buy something where I cannot use this I love satiellite radio and have docks in both vehicles, my boat, and house that I use my one subscription on. I don't want a satiellite tuner for this unit or they charge me more for multiple units. So I need a 3.5mm aux in the unit.

 

 

 

MY QUESTIONS ABOUT OGM1 ARE:

 

1. I noticed this unit has a "Media Link" and see it has a 3.5mm jack so that should take care of the SIRIUS issue. But I also have read about the external microphone for bluetooth connected to this medialink? Does it use the 3.5mm jack? If so that's a problem for me.

 

2. I want to have a back up camera and do not have one already, does it come with one? If not, what is my best option to buy with this unit?

 

3. Installing this in a W/T model equipped with a factory CD deck, is there going to be problems? I am very capable at installing stereo's and good with a wrench.

 

 

 

Anyone having any other suggestions of my options is appreciated.

Thanks for your time.

Link to comment
Share on other sites

The mic goes elsewhere. The media link will have the normal aux. jack and a USB port for iPod or similar devices.

 

It does not come with one but supports one and Walt can hook you up with it for sure (my truck has the OE unit so I don't have any more info on that).

 

Install was quite easy. I pulled the upper glove box to make routing the mic and GPS cables a bit easier but I also did this to do some modifications to the glove box as that was where I mounted the media hub. The whole thing is plug and play, no splicing or wire crimps.

Link to comment
Share on other sites

The factory unit works great in my opinion and should fit you requirements. here is a link to my install http://www.gm-trucks.com/forums/index.php?showtopic=147384. The cost is farely similar if driving and entering address or watching movies is not an issue for you. The kit from CPS does not require a dealer visit.

Link to comment
Share on other sites

The factory unit works great in my opinion and should fit you requirements. here is a link to my install http://www.gm-trucks...howtopic=147384. The cost is farely similar if driving and entering address or watching movies is not an issue for you. The kit from CPS does not require a dealer visit.

 

By that, do you mean I cannot enter addresses or watch video while the transmission is in drive? If so, no I want to be able to do whatever I want, possibly one of the worst restrictions I've ever seen. Sure I don't want people texting and driving but my passenger should be able to watch video and I should be able to change GPS destination on the fly. Obviously I would only attempt this at a reasonable time like a red light or freeway enviroment. Also I like how I would be able to locate my "media connect" in a place that will clean up my dash and allow me to place my SIRIUS DOCK to the window and not have a AUX cable sticking directly out the dash.

 

Also another question I have for OGM1 does it have voice support for GPS navigation.

 

 

Thank you for your suggestion, you have a very detailed install, great job!

Link to comment
Share on other sites

OGM1 will allow full use in motion but its disabled by default. It's enabled in a hidden menu. GPS will announce road names but you cannot command it by voice.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

The factory unit works great in my opinion and should fit you requirements. here is a link to my install http://www.gm-trucks...howtopic=147384. The cost is farely similar if driving and entering address or watching movies is not an issue for you. The kit from CPS does not require a dealer visit.

 

By that, do you mean I cannot enter addresses or watch video while the transmission is in drive? If so, no I want to be able to do whatever I want, possibly one of the worst restrictions I've ever seen. Sure I don't want people texting and driving but my passenger should be able to watch video and I should be able to change GPS destination on the fly. Obviously I would only attempt this at a reasonable time like a red light or freeway enviroment. Also I like how I would be able to locate my "media connect" in a place that will clean up my dash and allow me to place my SIRIUS DOCK to the window and not have a AUX cable sticking directly out the dash.

 

Also another question I have for OGM1 does it have voice support for GPS navigation.

 

 

Thank you for your suggestion, you have a very detailed install, great job!

 

 

 

You will want to careful in regards to playing a dvd on the ogm-1 screen. In Ontario you will get charged if the dvd screen is visible to the driver and a dvd is being played while vehicle is in motion.

Link to comment
Share on other sites

Just ordered one, and a backup camera with it.

 

 

What all comes with the back up camera?

 

 

The camera kit comes with the factory GM tailgate camera bezel (PN: 22755304) which has the lock housing that accepts the factory lock from your old bezel (or you can buy a lock cylinder kit from GM).

 

The camera is a "Super CMOS" camera that has parking lines built-in with great color depth, sharpness and amazing night vision and comes with a 25' extension harness for power/ground/RCA leads to reach to the deck.

 

All in all, it's the best camera kit we've ever seen for GM pickups...

Link to comment
Share on other sites

  • 1 month later...

Finally got around to installing this. It took me awhile because Im a bit of a perfectionist when it comes to my stuff.

 

There was a scary moment after I tested the unit and began putting the dash together, first the unit turned off. (I had the key in on, engine off) Next the dash started doing wierd things, dash actually stay lit when I took the key out. Crap, what could I have done I thought, so I disconnected the battery, reconnected and now it said service charging system. OH YEAH I forgot I had the dome light on so long and the truck hasn't moved in a month, THE BATTERY WAS ALMOST DEAD!

 

Thankfully I used my jump kit and all is well!

 

VERY HAPPY

Link to comment
Share on other sites

I have one (OGM-1)that I just got back from AudioVox.... The first Unit just up and died on me...no power or anything. Sent it in..got another back within 2 weeks. ...but this one is obviously a refurb because I now have XM(must have been a previous sub package) the main odd thing is the rear view camera that was working fine with the other unit is wonky. By that I mean once you connect the rear view yellow plug the image appears on the unit and you cannot control anything..no sound no changing out to the main menu...just the rear video of the car.

 

The part that is giving me a headache is that I just basically pulled the old unit out and sent it off...left all the connections in the car with NO changes. So now I have to disconnect my rear View camera until I get in touch with Tech Support. All in all...not crazy about the amount of headaches with this unit compared to the Alpine I bought for my wifes car around the same time.

Link to comment
Share on other sites

I have one (OGM-1)that I just got back from AudioVox.... The first Unit just up and died on me...no power or anything. Sent it in..got another back within 2 weeks. ...but this one is obviously a refurb because I now have XM(must have been a previous sub package) the main odd thing is the rear view camera that was working fine with the other unit is wonky. By that I mean once you connect the rear view yellow plug the image appears on the unit and you cannot control anything..no sound no changing out to the main menu...just the rear video of the car.

 

The part that is giving me a headache is that I just basically pulled the old unit out and sent it off...left all the connections in the car with NO changes. So now I have to disconnect my rear View camera until I get in touch with Tech Support. All in all...not crazy about the amount of headaches with this unit compared to the Alpine I bought for my wifes car around the same time.

 

 

Hit the Setup hard button, then Info and check the "MCU" line at the top. This should read something like OGM1-59-12-6-16. This is your firmware date. In this example, it would be June 6th, 2012.

 

It sounds like you have a unit the VERY old firmware.

 

Download the latest firmware version from www.adventproducts.com and I'll bet your issue goes away (along with getting a LOT more features...)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.