Jump to content

Engine Noise in Speaker


Recommended Posts

HELP - new to this forum, read several posts on the topic but can't find me exact complaint or fix.

 

I have an '05 Silverado with the Bose stereo, as I was driving down the highway today - the passenger front speaker started to crackle over the music, shortly after I now have constant engine noise / whine through the PS Front speaker. With the ign off / radio on, it goes away. When the truck is running, it's contstant noise and goes up / down with RPM. I'd really appreciate any feedback on this of where to look. I'm stumped because it's only one speaker - not the whole system. Stereo still sounds good, that speaker is still good sound wise.

 

THANKS!

Link to comment
Share on other sites

OK - removed door panel, consol and checked amp, speaker and everything looks OK. I feared something might have spilled and got on teh stock amp, but no problem found. I disconnect the alternator hot wire, the whine goes away. All grounds that I can see are in good shape. Again - I appreciate any ideas.

Link to comment
Share on other sites

Had a similar problem on my last truck with a whole system put in. Never was able to trace it, but it is a bad/insufficient ground somewhere in the system. Since it is just one speaker, it's probably got to do with the speaker wire or that particular channel's RCA.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.