Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

My XM radio stopped working in my truck two weeks ago. The screen is telling my signal is blocked, so when I called XM they refreshed the radio with no luck. Anyone else have this issue?

Share this post


Link to post
Share on other sites

My XM radio stopped working in my truck two weeks ago. The screen is telling my signal is blocked, so when I called XM they refreshed the radio with no luck. Anyone else have this issue?

Did one of these the other day that was the radio itself. Could be your high frequency antenna too. Could also be coax cable as well. This issue will require some diagnosis, unless you wanna throw parts at it.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Did they by chance walk you through the refresh process? Not just re-sending the signal.

 

I received an XM subscription for my birthday a couple weeks back and had a similar issue in my 2015 Silverado. Once they tried the re-sending of the signal, they walked me through the re-fresh of the system. It basically was a bunch of steps that I can't recall, but involved turning the truck on for 30 seconds or so, turning it off for 30 seconds, opening the driver door for 60 seconds, etc. After this was done, they re-sent the signal, and it worked. Make sure you do this outside, not in a garage or underground. Call Sirius XM for the step-by-step or chat with them online.

  • Like 1

Share this post


Link to post
Share on other sites

I actually contacted Sirius XM now for you for the details:

 

The following power cycle as per the steps below:

1. With your vehicle in an open area for reception, place your radio into Satellite mode.
2. Leave the receiver on for 30 seconds.
3. Turn the radio off and please remove car keys from ignition.
4. Open driver-side door fully and leave open for 30-40 seconds.
This is a soft reset of the SiriusXM receiver within your vehicle. Once complete please power the radio in your vehicle back on and place it in SiriusXM mode. Your receiver will require a signal refresh:
In order to send a signal refresh, you may visit us at: www.siriusxm.ca/refresh
Alternatively, you may reach us by phone at: 1-888-539-7474 then press 4 for refresh with your radio

Edited by SilveradoSaver
  • Like 1

Share this post


Link to post
Share on other sites

Do have factory gps and if you do, is it working? Is the lights green in the mirror of onstar?

 

Could be the onstar antenna

Share this post


Link to post
Share on other sites

There is something wrong with the hardware or software of your actual radio. If it thought you didn't have a subscription it would default to 2 stations. Their preview station and another that tells you the radio id.

 

Your antenna cable could have come loose or something, but if it's under warranty, this is a GM problem. I would take it in.

 

If not under warranty, I would check the connections at the radio module paying close attention to the XM antenna. If that looks fine, you can buy xm antennas very cheap. Buy one and try it out. You may not get perfect reception (due to the roof), but you can technically leave that antenna under the top layer of the dash. It should only really affect your reception in the northern states. You may also be able to find a diagnostic test in the hidden menu for your radio. I think it's holding home, menu and power or something like that.

 

If it's not the antenna, or as someone else mentioned, resetting the radio, you're probably looking at replacing more expensive parts and it may be worth it to have the dealer diagnose it, if only so you're not throwing money away.

 

 

Sent from my iPhone using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
On 8/31/2017 at 8:14 PM, jhplak325 said:

Do have factory gps and if you do, is it working? Is the lights green in the mirror of onstar?

 

Could be the onstar antenna

Yes, I have factory GPS and it is working. Yes, the green lights are lit.

Share this post


Link to post
Share on other sites

Still no luck with the XM. Going to take it to the dealer and have them troubleshoot it.

Share this post


Link to post
Share on other sites

I'm curious if/how you got this issue fixed. I also have a 2015 Silverado with this exact same issue.  Dealer wants $190 just for a diagnostic test,  maybe I'm too cheap but that seems steep to me. So thru my research I found this site, hoping to find some answers. Any help is appreciated!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.