Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

I have a 2003 Chevy Silverado 1500hd, I have changed the t-case, the actuator, the dash buttons, the TCCM, the encoder motor, cleaned the cables on the frame, checked the wires from tcase to under the hood, and for some reason the lights on the 4wd buttons won’t work, they light up when you turn the key on but once the motor starts the lights go out and stay out. I can’t get the tcase to engage, the reverse only operates when the motor is hot, I’m at a loss, help me please. 

Share this post


Link to post
Share on other sites

I think you need to tell us what started you down this road in the first place. Why did you replace all these parts?

 

Share this post


Link to post
Share on other sites

Was the dash switch assembly Brand new?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.