Jump to content

Wiring harness?


Recommended Posts

Bought a new sailboat and trailer over the weekend. Had to assemble the trailer piece by piece and I hooked up the wiring on it correctly. hooked it into a 4 plug adapter I had to fit my truck which has the 7 plug circular setup. It seemed only the drivers side trailer brake light would come on when i pressed the brakes and the pass. side would stay off. Same for turn signals, only dr. side would blink. Tried hooking it up to my buddies 4runner which has a stock 4 plug wiring harness on the hitch and it worked perfectly. Is there some sort of trick to getting the lights to work with my truck, or do I maybe have a bad wiring harness on the truck? Any help is appreciated.

Link to comment
Share on other sites

check your fuse under the hood of your truck, sounds like you didnt have a ground on tight and it shorted that side out. look in the manual or under the hood there are different fuses for the two sides, had this happen to me.

Link to comment
Share on other sites

great, found where all that stuff is in the owners manual. hopes its just as simple as a cooked fuse. guess ill have to check all the trailer fuses and make sure all the grounds on the trailer are tight. let ya know how it works out

Link to comment
Share on other sites

had 2 fuses blown and i had accidentally pinched one of the trailer wires underneath a bolt and broke the connection. changed the fuses and fixed the wire and everything works! thanks a lot!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.