Jump to content
  • 0

99 Silverado 2500 Wont Start


99WorkTruck

Question

I took the seats and carpet out of my 99 Silverado 2500(6.0L) last week so I could install new carpet. I was drivng around all week with just the two bucket seats untill the crapet was delivered. Well I got the carpet today and after installing it, the truck wont start. I did not cut any wires when installing. The truck will crank and barely start and then it just cranks with an odd noise. Too me it sounds like its some safety switch cutting the engine out right after it starts to run. The truck is completly stock. Any suggestions? If it helps after trying to start the battery light stays on.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

I'm thinkin' you disturbed something up under the driver-side dash. Maybe something's half-way unplugged. I'd experiment by pulling off the driver side kick panel (that plastic panel that's to the left of the driver's feet) and I'd peel back the carpeting on that side. Then I'd get one of those everready LED headlights for $10 in the sporting goods department at walmart and I'd carefully examine all the connectors in that area.

Link to comment
Share on other sites

Thanks for the suggestion. I checked all the connectors and they all were hooked up. I feel like there is some kind of secureity that is locking me out. Will the system lock you out if you have the doors open for a long time? I had all the doors open for a long time while installing the interior and had the key on and off at different times. I can hear the fuel pump go on and then I let it prime and it will start for a slight second and then turn off. I also noticed that none of my gauges are turning on when I turn the keyt ot he on position.

 

Any other suggestions?

 

Are there any procedures to reset the ecu?

 

thanks for the help, Brian

Link to comment
Share on other sites

did u plug in the airbag plug underneath the drivers side back into your chair? I havent yet since i installed a new stereo but thats one thing i could think of. Its yellow i believe and hard to miss. I dont know if its important to plug in or if it could cause a security problem.

Link to comment
Share on other sites

Thanks for the suggestion.  I checked all the connectors and they all were hooked up.  I feel like there is some kind of secureity that is locking me out.  Will the system lock you out if you have the doors open for a long time?  I had all the doors open for a long time while installing the interior and had the key on and off at different times.  I can hear the fuel pump go on and then I let it prime and it will start for a slight second and then turn off.  I also noticed that none of my gauges are turning on when I turn the keyt ot he on position. 

 

Any other suggestions?

 

Are there any procedures to reset the ecu?

 

thanks for the help, Brian

 

 

 

YOU ARE HAVING A SECURITY SYSTEM FAILURE EITHER THE KEY CYLINDER OR PASSLOCK SENSOR TAKE IT TO THE DEALER AND TELL THEM

WHATS GOING ON THEY HAVE SEEN IT BEFORE :cheers:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.