Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Oil pressure went to 120 max setting and then under throttle goes to 0 almost instantly. Cut off engine and oil was full and had no leaks. Started it back and no noise from lifters or engine knocks. Oil pressure now stays at 0. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Alexhawk94
      Hello everyone, i'm asking for advice & help you guys. 
      I know it's not a good way to start with asking help, I'm sorry bout this.

      Let me shortly introduce myself - my name is Alex, I live in Russian Federation, Moscow and I drive 2006 Chevy Tahoe (gmt 800) with 5.3 Vortec engine (simple gas, no flex fuel). 

      I am facing a problem with my oil pressure gauge - while driving or at idle oil pressure gauge jumping from 0 to max value. It may stuck at 0 for long time (hour or so) or can stuck at max value also.
      When I switch ignition on gauge does NOT jump to max, everything seems to be ok for at engine start but soon gauge become messy. As a pressure falls to 0 I have an alarm warning with horn and alarm in message centre. When this happenes, gauge jumps to max and when falls down again sometimes.

      I'd like to mention that there are not any strange sounds with engine (no knocking or something) when pressure falls down. 
       
      Since I did not find a particular my problem at different forums, I decided to ask you guys. Also it's a bit difficult to maintain and service such vehicle here in Russia, so I would really appreciate for any advice of community. 
       
      I recorded some videos with mess going on with my vehicle and uploaded them to YouTube so I can share them with you.

      https://www.youtube.com/watch?v=RbPpOAKi2D8
      https://www.youtube.com/watch?v=Lbm4Gn3YYzI

      I found in rockauto store this new acdelco oil pressure sensor ACDELCO 12677836 - is this correct partnumber for me?

      Any advice and help truly appreciatable.


       
       
      P.S.: thats my second GM truck, the previous one was Tahoe 1996 5 doors 5.7 Vortec engine
    • By Louie0913
      Ok guys I can not be the only one with this problem I have a 2004 Chevy Silverado with a 5.3 I know that I need to change the oil pressure switch I have the correct socket and actually did this several years ago .. My delima is I put a Magnuson Supercharger on in January I love it really woke up my truck But I cant get the socket on to the sending unit If Anyone has done this please share Im really stuck and dont want to disassemble my truck to do this Thanks in advance



  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    230,559
    Total Topics
    2,462,625
    Total Posts
  • Member Statistics

    229,354
    Total Members
    8,960
    Most Online
    lonnie cooper
    Newest Member
    lonnie cooper
    Joined
  • Who's Online   44 Members, 0 Anonymous, 1,628 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.