Jump to content
  • 0

Reverse lights don't work, what did I F%$# up?


samckitt

Question

I was attempting to check which terminals were the hot & ground in the socket for the backup lights & now they do not work. Truck is a 2003 SIlverado 1500HD LT. I checked the fuses & all look good. Is there a relay for the backup lights? Did I burn up something in the body control module? Any other ideas?

 

Thanks,

Scot

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

I was attempting to check which terminals were the hot & ground in the socket for the backup lights & now they do not work.  Truck is a 2003 SIlverado 1500HD LT.  I checked the fuses & all look good.  Is there a relay for the backup lights?  Did I burn up something in the body control module?  Any other ideas?

 

Thanks,

Scot

 

 

 

 

 

There is a module that is on top of the transmission, have you checked that?

Link to comment
Share on other sites

No I haven't checked this module you are speaking of. I should also mention that when it is dark & I unlock the doors these backup lights come on to provide perimeter lighting so you can see around it. They don't come on now either when I unlock it. Do you think I should check this module on the tranny?

 

Thanks,

Scot

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.2k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    333,913
    Total Members
    8,960
    Most Online
    Al L
    Newest Member
    Al L
    Joined
  • Who's Online   5 Members, 0 Anonymous, 651 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.