Jump to content
  • 0

Problems with 2008 5.3


David_L6

Question

Truck is a 2008 Silverado with a 5.3 with ~79000 miles on it. Never had any problems with it the first 4 years I owned it. I've never had the oil consumption problem that others have had.

 

A week ago the oil pump went out. Dealership replaced the oil pump and 2 days later the oil pressure was all over the gauge, check engine light was on, and truck idled rough. Dealership said that it was lifters and cam and they replaced both.

 

Now the oil pressure runs both lower and higher than it used to. It used to run right around 40 all the time. Little lower at idle and a little above at highway speeds. Now it runs about 22 at idle, 38 at highway speeds, and jumps up to about 58 if you get the RPMs up while passing, etc.... What's the deal???

 

I have 3 Silverado trucks. A '99 with a 4.8, this 2008, and a 2012 with a 6.2. Until this problem with the '08 they all had oil pressure right around 40 all the time. Never much below or above 40.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Mine has recently started doing the same exact thing (although mine is older generation.) I haven't done anything to fix mine since I don't get any warning lights and my oil level is closely watched. So if you find a fix let know.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.