Jump to content
  • 1

Cruise Control Stopped Working


SSSilverado23

Question

Recommended Posts

  • 0
Check fuse first, brake light switch second

 

Sent from my DROID RAZR MAXX using Xparent Red Tapatalk 2

 

Fuse is good. I do get brake lights when I push the peddle. So I think im good there.

 

Sent from my SCH-I605 using Xparent Red Tapatalk 2

 

 

Link to comment
Share on other sites

  • 0

As long as they dont stay on. That's what kicks the cruise off. I lost cruise once but it came back like an hour later. I can't think of anything else. Have you changed anything like put LED's for brake lights?

Link to comment
Share on other sites

  • 0
As long as they dont stay on. That's what kicks the cruise off. I lost cruise once but it came back like an hour later. I can't think of anything else. Have you changed anything like put LED's for brake lights?

 

Naw I havent done anything. Im so tired of dealing with electrical things with this truck. It was working fine before. Now its not turning on at all.

 

Sent from my SCH-I605 using Xparent Red Tapatalk 2

 

 

Link to comment
Share on other sites

  • 0
didnt you get that truck not to long ago? take it back to where you got it and let them deal with it
7 months ago. I wish it was that easy. Sent from my SCH-I605 using Xparent Red Tapatalk 2

 

Come on man....you've got to stop w/ all these electrical issues :D....just let me know if you want need some tech info on it.
I definitely would like some tech info! Im sick of it man.....Sent from my SCH-I605 using Xparent Red Tapatalk 2
Link to comment
Share on other sites

  • 0

Here are the schematics (from an 05)....most of the problems I've seen w/ these things are attributed to the multifunction switch. Unfortunately the troubleshooting procedures won't do you any good since you need a tech2 to use them.

cruisecontrol.pdf

cruisecontrol.pdf

cruisecontrol.pdf

cruisecontrol.pdf

  • Like 1
Link to comment
Share on other sites

  • 0

Here are the schematics (from an 05)....most of the problems I've seen w/ these things are attributed to the multifunction switch. Unfortunately the troubleshooting procedures won't do you any good since you need a tech2 to use them.

 

Ok so basically i need to trace wires and if the wires are good start be replacing the Multi function switch? I know its not the brake light switch. thanks for everything!

Link to comment
Share on other sites

  • 0

You said in your other thread that the cruise was working today.....are you positive it's not the brake switch? If you aren't positive then I'd keep driving it and the next time it happens pull back on the brake pedal w/ your foot and see if it will engage. Not sure about your truck but my truck has no indication that the cruise is in the on position....just the light on the IPC when it's engaged.

 

No let me see if I've got the other thread straight.....the second DDM was bad?

Link to comment
Share on other sites

  • 0

You said in your other thread that the cruise was working today.....are you positive it's not the brake switch? If you aren't positive then I'd keep driving it and the next time it happens pull back on the brake pedal w/ your foot and see if it will engage. Not sure about your truck but my truck has no indication that the cruise is in the on position....just the light on the IPC when it's engaged.

 

No let me see if I've got the other thread straight.....the second DDM was bad?

 

 

I replaced the brake switch a week after i bought the truck. I suppose it could be bad but its not even 7 months old. So i automatically ruled that out.

 

My DDM was bad and the first one i bought was bad. The second one worked but i bent the rod today changing the actuator back to the original.

Link to comment
Share on other sites

  • 0

Since it was working recently I'm not sure what else we can do at this point. I'll look over the schematics again but the next time it won't engage give the brake pedal a try.

 

I drove it today and it wasnt working again. Messed with the brake pedal and still nothing. Its definitely not the brake switch. I guess without a tech 2 should just pull the column apart a bit, check the wiring and start by replacing the multi function switch?

Link to comment
Share on other sites

  • 0

There are probably a few things you can check with a multimeter. I'll look over the schematics tomorrow and give you my recommendations. My bet would be on the MF switch though since that is what recieves the most wear and tear.

Link to comment
Share on other sites

  • 0

There are probably a few things you can check with a multimeter. I'll look over the schematics tomorrow and give you my recommendations. My bet would be on the MF switch though since that is what recieves the most wear and tear.

 

Ok cool. I appreciate it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.