Jump to content

Air Raid MIT Problem


Recommended Posts

for some reason my air raid intake tube keeps coming loose from the throttle body? iv tighened it down several times and even switched the rubber ends to see if it would stay on better. any one else having problems with their tube staying on? if so how do yall keep it from coming off

Link to comment
Share on other sites

^ like he said. Also make sure it's seated all the way and evenly on both sides I know a couple times I went to tighten down and it wasn't seated or overlapped all the way so if I had drove it would have popped off.

Link to comment
Share on other sites

when I had the volant, if you connected the intake last, it would be hard to connect and even harder to keep connected. I ended up connecting the engine side first, then connect to air box. Did not come off again.

Link to comment
Share on other sites

  • 3 years later...

I know this is a little late to respond to this topic, but I figured I would add this for future reference. This goes back to my days of turbo motors and intercooler pipes. A little trick to help the couplers to stay in place is spray some hair spray on the inside lip of the coupler and put it on. It will dry sticky and help it hold in place.

Link to comment
Share on other sites

  • 2 months later...

I don't have this slipage problem but I do have a problem since installing an AirRaid intake tube. '13 Sierra SLE w/ 5.3.

 

I installed the Jr tube (running a K&N filter in the stock air box). Now under moderately hard acceleration or WOT, I get a loud, horrible sound like a vibration/grinding/rattle/howl from the passenger side under the hood. It's not the normal air groan/moan sound of the air intake when you get on the gas. (I've had cold-air intakes on several trucks.) This almost sounds like the K&N is jumping up and down rapidly or oscilating up and down or vibrating due to the volume of air going thru it. I had the K&N on the truck for more than a year with the stock air intake tube and never heard this racket. Everything is snug, nothing is loose. I don't see any visual problem with the K&N. Anybody have any ideas on what the noise could be coming from? I'm ready to put the stock intake tube back on. I'm new to this site and appreciate the help.

Link to comment
Share on other sites

  • 1 year later...

I emailed air raid tech support since mine was falling off the throttle body once a month. They had me send a picture of the mit installed. They promptly sent a more flexible silicone coupler and I haven't had issues since.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.