Jump to content

Screen problem


Recommended Posts

Hey all, driving home tonight, and the display screen in my 2014 Silverado started acting up. See the video here:

 

 

 

I had noticed about a week ago, when listening to the radio, and displaying the audio tab, the presets disappeared. I figured there was a setting or something that I inadvertently changed, and spent a little time trying to see if I could figure out how to get the back, but never could.

 

I don't know if that issue is related to the screen blinking, but I figured I would mention it. As you can see from the video, everything seems to work, I turned off the radio when I took the picture, but it was working while blinking. The Nav and phone functions seem to work too.

 

Anyone seen this?

Link to comment
Share on other sites

Looks like a software corruption, you can try resetting it to factory setting if it is in the options (i will have to check where, but there is one, I have seen it)

 

And go check your version, i think the key combinations is power menu and home pressed at the same time. Look for 0474 for the version somewhere

  • Like 1
Link to comment
Share on other sites

Hey all, driving home tonight, and the display screen in my 2014 Silverado started acting up. See the video here:

 

 

 

I had noticed about a week ago, when listening to the radio, and displaying the audio tab, the presets disappeared. I figured there was a setting or something that I inadvertently changed, and spent a little time trying to see if I could figure out how to get the back, but never could.

 

I don't know if that issue is related to the screen blinking, but I figured I would mention it. As you can see from the video, everything seems to work, I turned off the radio when I took the picture, but it was working while blinking. The Nav and phone functions seem to work too.

 

Anyone seen this?

Hey there,

 

We certainly understand how frustrating this may seem, and we would be more than happy to bring this to your dealership's attention. Feel free to send us a private message along with your VIN, current mileage, contact information and a preferred dealership. Looking forward to your updates and response!

 

Patsy G

GM Customer Care

Link to comment
Share on other sites

I'm sure GM will fix it just like the fm reception, steering vibration and seat issues. I'm about to get a Ford. This '14 high country 4x4 has been a true disappointment.

 

 

Sent from my iPhone using Tapatalk

  • Haha 1
Link to comment
Share on other sites

There was an update back after the 14's first came out, make sure that was done or that they have the newest update installed as it addresses some of these issues.

Link to comment
Share on other sites

  • 3 years later...
On 4/26/2015 at 7:53 PM, GMCustomerService said:

Hey there,

 

We certainly understand how frustrating this may seem, and we would be more than happy to bring this to your dealership's attention. Feel free to send us a private message along with your VIN, current mileage, contact information and a preferred dealership. Looking forward to your updates and response!

 

Patsy G

GM Customer Care

We are having the same issues with our 2015 Silverado 2500. Can you tell me how to correct this issue with this radio screen glitch?

Link to comment
Share on other sites

  • 6 months later...
  • 5 months later...

Hi Folks, Happy Thanksgiving!

 

Old thread but same problem. My 2015 Silverado has strange screen gremlins and it affects the smaller info screen behind the wheel as well. Switches channels on its own, flickers, etc.

 

Any solution to this issue? Seems software related but when I asked a dealer they said they doubted that. Frustrating!

 

Thanks!  

Link to comment
Share on other sites

  • 1 year later...
  • 3 months later...

Worked on a 2017 Yukon with the Intellilink screen flickering. Found the Human Interface Control Module Bypass Module. RPO Code: K188. It is located just left of the steering column. Had internal connector fretting. I Unplugged and plugged back in the connectors. Remounted the module. Screen acts normal.

Link to comment
Share on other sites

The only problem that I've had with mine is the whole unit would randomly/rarely reboot.  And the night before my battery completely died, the entire unit would NOT boot up.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    333,498
    Total Members
    8,960
    Most Online
    MadMedeiros
    Newest Member
    MadMedeiros
    Joined
  • Who's Online   4 Members, 0 Anonymous, 786 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.