Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

DenaliKing

2016 GMC Sierra Denali 6.2 won't start

Recommended Posts

I went out to get in my truck Saturday, to fire it up so we could take the kids to a family friend's birthday party. I hopped in, put the key in the ignition, and the infamous click click click... So I just got a battery about a year ago for a somewhat similar situation with a bad battery, so naturally I was like WTF... got my volt meter out, and sure enough battery was sitting at 11.9 volts, now here's where it get's strange, I pull the battery to take it in, and I decided to check it just to see, and it was now at 12.6??? Still technically low enough to be a bad battery (91%), but not nothing like you'd typically see. So I took it in anyway and they graciously swapped it under warranty. So I'm done right? Wrong!!! I get home and put it in, walk around to start her up, now when I put the key in it'll only ding, nothing else.... no radio, no display, not even the click I was getting earlier.... so now I send the family without me, and I'm about to investigate. Computer wouldn't allow me into the pcm, but it would allow me to check for open circuits, which I had an ignition open circuit, I check all available fuses, and there's alot of em, 3 banks worth, they were all fine..... what the hell.... so then I looked at the battery terminal (buss bar), checked all circuits, I had a dead 175A terminal, bingo!!!! Went to the dealer, it's a 92 dollar part, and all is now well... it took me the better part of the day to figure this out, so I'm hoping this may help short cut some of you with the same type problem... dealer said this item goes out often, and for no apparent reason.. links to pictures, and part numbers attached. Happy mechanicing

20201018_111905.jpg

20201018_112052.jpg

20201018_112059.jpg

20201018_112119.jpg

  • Like 4

Share this post


Link to post
Share on other sites

Nice. Thanks for sharing.

Sent from my SM-N975U using Tapatalk

Share this post


Link to post
Share on other sites

Nice find. I'll file that one away for later just in case.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.