Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

stevew88

2016 Silverado Mylink screen issue

Recommended Posts

Hey all! Disappointed that my first post is going to be a negative one but i'm curious to see if anyone else is having this issue.

 

2016 Silverado All-Star edition. Since I purchased the truck on 12/31, I've had this issue six times. You start the truck and the 8" Mylink screen is blank. No power - cant turn it on, no radio, etc. It's happened under different scenarios, after remote start, key start, etc.

 

it's back at the dealer for the second time. They called me and said there's software updates to fix this issue. The salesman indicated that this is a big issue on 2016 Chevy's - cars and trucks.

 

Anyone else have this issue on their 2016? I've read about 14's and 15's, you'd think a 2016 would already have the updates.

 

I love the truck otherwise!

 

--Steve

Share this post


Link to post
Share on other sites

my 2016 has been fine since I got it on 12/15

  • Like 1

Share this post


Link to post
Share on other sites

So far haven't had issues since the software updates.

Share this post


Link to post
Share on other sites

This is off topic a bit but I wanted to see if anyone reading these radio related posts might be familiar with a radio problem I am having. I have 2015 GMC Sierra and since installing new HID headlights I can't assign stations to all my presets. I can only use certain radio presets numbers and on top of that I can't assign any XM stations as presets.

Share this post


Link to post
Share on other sites

No issue here. I bought it on 12/23/16

Share this post


Link to post
Share on other sites

Hey all! Disappointed that my first post is going to be a negative one but i'm curious to see if anyone else is having this issue.

 

2016 Silverado All-Star edition.

 

Anyone else have this issue on their 2016? I've read about 14's and 15's, you'd think a 2016 would already have the updates.

 

--Steve

14's and 15's have different radios, so software fixes for them do not apply to the 16's and vice versa. Also fixes are only applied as problems are reported. When it comes to software and hardware versions, don't assume you have the latest unless dealer confirms it.

Share this post


Link to post
Share on other sites

so far mine has been good. 10/15 build date purchased saturday after thanksgiving.. i have had the pandora bleed through during a phone call to a doctor, that was interesting i thought it was on his end lol.. then i realized it was billy joel which i was listening to before!

Share this post


Link to post
Share on other sites

So far haven't had issues since the software updates.

That's good to hear. I've had issues with CarPlay, but I don't believe it's directly related to what you were experiencing. Do you know what they updated on your truck? If they simply updated the MyLink, what software version did they update it to? Should be in your Settings.

Share this post


Link to post
Share on other sites

That's good to hear. I've had issues with CarPlay, but I don't believe it's directly related to what you were experiencing. Do you know what they updated on your truck? If they simply updated the MyLink, what software version did they update it to? Should be in your Settings.

What issues have you had with CarPlay? I had one issue where it disconnected and reconnected but haven't had it happen again. I believe they just updated the MyLink software. I'll get the software version tomorrow.

Share this post


Link to post
Share on other sites

Well my truck is back at the dealer for the same issue again!

Share this post


Link to post
Share on other sites

Got the truck back from the dealer on Monday. At first they told me they replaced a module but apparently that wasn't the case. The paperwork says an issue in the x275 connector under the dash near the hood release. Pin 11 was misaligned causing the issue. So far, its working fine - but we'll see.

 

Took about a week last time for it to act up again.

  • Like 1

Share this post


Link to post
Share on other sites

They use the term screen won't wake up. My 16 is good but my 14 had the problem and the update fixed the screen and created numerous issues that they couldn't fix.

Share this post


Link to post
Share on other sites

it happened on my 14, more times than I can remember. 3 days after driving it home. Each time it blacked out, I still had a working radio.. As in even though it was black, I could guess where buttons were and change stations. Only thing that didn't work was the volume nob. The steering wheel controls worked fine.

 

Every time I took it in, they said it's called 'logic lock' and their fix was to see if there was an update and or disconnect the battery. I don't like the morons there and if I kept band-aid-ing a broken item at my job, I'd get fired.

 

So when it happened again, I took it there while it was black. Left it running so they could see it not working. I wasn't taking another update fix anymore. I was adamant about what they've done prior wasn't working. They had my truck for a week replaced the hmi screen and a cable. Was good for a month and it happened again.

 

Took it back, they had it for another week and replaced other stuff and calibrated the door switch? Whatever they did seemed to do the trick. Haven't had the problem in months. Knock on wood.

 

I'll dig up my paper work to see what they replaced if it helps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.