Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Well that sucks because mines on it’s way from China now.  I’ll post if it happens to work well

Not to change the thread but can anyone get me to a link for adding Qi wireless phone charger for 2016 sil with split bench seats  truck didn’t come with one, just need info as to options. Thanks

I got my Carplay2air a few weeks ago and has been flawless in my 2020. I didn’t update it to the newest version as it works perfect and don’t want to chance the update screwing it up. It connects ever

For anyone interested...
I asked C2airplay if it would work on my 20 Silverado 2500. They told me if my truck had  “C Port” in the console, then it would not work. 
I confirmed I had C Port, but ALSO had regular hdmi port. They responded that it would still not work. Apparently the mere presence of the C Port makes it incompatible right now. I don’t know why, but that’s what they said. 
 
So anyone who has LTZ or HC, probably has issues with it. Hope this helps. 


Could be my issue but it works intermittently. Not a big deal as I am using it flawlessly in my car.


Ryan B.
Link to post
Share on other sites
Amazon sells this one through Prime so I guess you could try it out and if it doesn't work send it back.  Beats waiting for China shipping and restocking fee.
 
https://www.amazon.com/dp/B08FC3B2QF/ref=sr_1_4?dchild=1&keywords=wireless+carplay&qid=1599262746&sr=8-4
OOS
Not sure about returns because it doesn't look like a Prime sale

Sent from my SM-N975U1 using Tapatalk

Link to post
Share on other sites
On 9/2/2020 at 11:33 AM, txab said:

The Great One has returned!  :D

 

 

we.png

 

Haha! I bought the CPlay2Air module and can't get it to work in my '19 HC.

 

spacer.png

 

Hope you folks are doing well!

 

Link to post
Share on other sites
  • 2 weeks later...

Received the CarPlay2Air yesterday, and it worked right out of the box. I undated the firmware, after that it would not connect to my 2017 LTZ. I followed the instructions to totally disconnect it and then reconnected it, that did not seem to help. I tried that again (did not seem to work) and then went for a drive. After a few minutes the carplay button came on, but I could not run carplay, hitting the button did nothing. I power-cycled the media player, and hit the carplay button again. Carplay launched via CarPlay2Air and it just worked. Worked for the rest of the day. It does take some time to connect (up to 20 sec) when I leave and return to the truck.   We will see how it works today.

Link to post
Share on other sites
  • 3 months later...

Waking up this thread for anyone who has still has their CPlay2Air and/or Carlinkit (They are the exact same) and still have not gotten it working.

When I went to update the dongle, the highest version it was giving me was 2020.10.28 but I figured out you can manually flash the firmware using a usb flash drive. I AM NOT RESPONSIBLE FOR ANY MESS UPS YALL CREATE, Flashing firmware like this could Brick the dongle and make it completely useless!

 

Here are the steps to Flash a higher version of the firmware

 

1.) format a flashdrive of any size (USB A) to FAT32

 

2.) Download the firmware from https://github.com/ludwig-v/wireless-carplay-dongle-reverse-engineering onto the now formatted flashdrive, I Used the Custom 2020.12.10 and it works perfectly for my truck (Make sure to rename the file to U2W_Update)

 

3.)Connect the CPlay2air/Carlinkit to a USB wall adapter, wait for the solid red light

 

4.)put the flashdrive into the usb port  on the dongle (red and blue light should start flashing back and fourth)

 

5.) GIVE IT 5 MIN to finish flashing

 

6.) Solid red light should appear when finished

 

7.) when finished, unplug the dongle from wall adapter then remove flashdrive from dongle and plug into Silverado!! should work great!

 

If red light doesnt appear you may have bricked the device and now it is garbage. (still try it out)

 

here is a thread I read that might answer any more questions you have (page 187):

https://forums.macrumors.com/threads/carplay-adapter-to-convert-to-wireless-carplay.2193978/page-187?post=29208724#post-29208724

 

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.