Jump to content

MikeAg

Truck goes into limp mode, throws heavy smoke when driving on freeway. Help!.

Recommended Posts

I have a 2005 2500hd duramax 6.6l LLy. I have been having a problem with my truck when I drive on the fwy doing over 65mph, the vehicle with go into limp mode and throws a ton of smoke. The only codes I get are for my mass air flow sensor, I've cleaned it several times and replaced it with a brand new one , and still no difference. I have a s&b intake with a S&b turbo mouthpiece,  which I thought could be throwing off the mass airflow sensor, but those are the only upgrades I have on it. Cant seem to find a answer anywhere, figured I would try here. Any help is appreciated. Thanks!

Share this post


Link to post
Share on other sites

Out of curiosity, do you have a Def fluid system installed on it? If so like mine, after the fluid is gone, it won't allow me to do over 60mph. Other possible traits with what your describing, start small and run a half can of sea foam in 15 gallons of diesel and see if it is just water in tank and injectors. If it persists, check spark plugs, if still happening, time to change out injectors. 

Share this post


Link to post
Share on other sites

DEF was not introduced until the 2010/2011 trucks.  He has a 2005.  No stupid DEF, no stupid DPF. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.