Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

zzrsouth

sunshade pulls up winshield gasket

Recommended Posts

Posted (edited)

This happen to anyone else?  This happened to me on the drivers side when I first got the truck and now it's happening on the pax side.

 

Ive used sunshades on all my vehicles pretty much forever and not had this problem before.  SUPER annoying, anyone else similarly affected?  Trying to decide if the gasket is incorrectly installed or not...

20190805_125538.jpg

Edited by zzrsouth

Share this post


Link to post
Share on other sites

Weird!

I just noticed this on mine today...lol.

Share this post


Link to post
Share on other sites
Posted (edited)

I have been using mine for over 5 months, 5 days a week. i haven't noticed this.

Edited by BlancoSilverado

Share this post


Link to post
Share on other sites

Wow. I would not be too happy about that.  No issues with mine so far and i use it everyday in 100+ degrees. Hope it stays that way! I’d take it to the dealer personally. Make them fix it.  

Share this post


Link to post
Share on other sites

I have the GM sunshade. It’s excellent. I’ve never had this happen, either, and it’s been routinely close to 100° here in TX lately. 

Share this post


Link to post
Share on other sites

I have same issue, on passenger side, using aftermarket sunshade 

Share this post


Link to post
Share on other sites
14 hours ago, econometrics said:

I have the GM sunshade. It’s excellent. I’ve never had this happen, either, and it’s been routinely close to 100° here in TX lately. 

And that may be the trick! I use the accordion type UVS Covercraft (identical to GM without logo), Easy to install but more importantly a dull silver/color finish reflective surface with heavy felt covered stiff poly backing. Stopped using those lightweight cheapo sunshields with highly reflective shiny surfaces and much less mass to absorb heat and as a result reflect more heat than the GM/Covercrafts......right onto the windshield......so much heat it can soft and compromise the factory windshield sealant.

 

Doesn't take too much to figure this out, all you have to do is measure the windshield temperature with each type after a few hours pointing at the hot Sun.

Likely after using the shiny cheapos the windshield will develop leaks and/or the insulating foam crawls out. Been using the heavy accordion types since the '06 Colorado and never had a windshield leaks or stuffing crawl out.

Share this post


Link to post
Share on other sites

Yeah, I bought a new, cheapo one at Pep Boys when I got my RST. Used it about a week and realized that with my black leather interior, the thing was worthless. 

 

I redeemed some GM rewards points to get the $125 GM shade with "Silverado" on it for $70. It works SO much better, and it LOOKS much better, too. The thickness of it clearly keeps a lot more heat out. 

Share this post


Link to post
Share on other sites

What does that gasket do? I think the morons at my tint shop removed mine when I had my windshield tinted. Reason I know is because I remember seeing that gasket sticking out a bit at two different places when I first purchased it.

 

Haven't seen it since taking it to the tint shop.

Share this post


Link to post
Share on other sites

It just seems stuck against the bottom if the windshield under the dash panel without anything really sandwiched against it.  That's why I wonder if its installed improperly.

Share this post


Link to post
Share on other sites

Mine is like that too. I’m just gonna tint my windshield already I’ve been putting it off
Being in south Texas it’s hot down here

My dumb sun shade made mine come up too

Share this post


Link to post
Share on other sites

Mine is doing it too.  I searched around and found that almost every manufacturer/brand has some issues with this.  I'm going to try and stuff some backer rod in there.  I have some 1/2" backer rod, but may be too big...I'll report back how it goes.

 

Share this post


Link to post
Share on other sites
15 hours ago, NeverCold said:

Mine is doing it too.  I searched around and found that almost every manufacturer/brand has some issues with this.  I'm going to try and stuff some backer rod in there.  I have some 1/2" backer rod, but may be too big...I'll report back how it goes.

 

1/2" backer rod is too big.

Share this post


Link to post
Share on other sites

Unbelievable. Same thing on passenger side just happened to me. I have been using the cheapo accordion style.  I live in CA and it’s only been in the 80’s +. I still don’t understand how the sunshade causes this problem. Can someone please explain? Also what is the fix and does the OEM sunshade cause the same thing? Thx

Share this post


Link to post
Share on other sites
55 minutes ago, Street Queen said:

...does the OEM sunshade cause the same thing? Thx

It hasn’t on my RST. I’ve had the OEM shade about 2 months now. Works great. Worth the $, IMO. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.