Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Hey y’all, new to the forum and to chevys here (used to drive an 84 Jeep CJ) and bought my K5 a few days ago

 

off the bat it came with a few problems the guy who sold it told us about, he said that the brake light bulbs would pop while driving, but we took it home (had someone drive behind us) and confirmed that we don’t have brake lights (the bulbs are not blown) or turn signals (front or back) and when we got home I confirmed that the backup lights and hazards (all four corners) do not come on either. And this didn’t happen when we first got it, but the morning after I found the interior light on and had to take the bulb out (wouldn’t turn off) in the fear of running out the battery

 

however, the taillights and the dailys (I’ve heard those little yellow lights on the sides called that before but I don’t know if that’s the proper term) do come on when the headlights are turned on. 
 

ive checked the fuses for the brakelights and turn signals and nothing seems to be wrong with them, so I’m assuming there must be something wrong in the steering column, but I’m at a loss of how to go about fixing the problem, and I’d love to get some advice before i go about taking the thing apart or having a shop look at it.

 

anything is greatly appreciated, thanks!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By austin jez
      Hello all. I have a 2013 silverado w/5.3l flex vin 7. Basically has rough idle in park and drive. Very poor acceleration. Almost seems to bog down when trying to accelerate. It will occasionally surge and for just a split second I can feel a bit of power.  Also doesn't want to downshift when I lean on the gas pretty heavy. I've got to do near floor it to get it to down ****** and when it does it will drop down 2 gears a lot of the time. No engine light and it won't set any codes. Showed 0 misfires on all cylinders. Long Fuel trims usually in single digits negs. Fuel pressure 43-46psi at idle and highway. I've replaced throttle position sensor, Accelerator pedal position sensor, manifold pressure sensor, mass air sensor, plugs, coolant temp sensor, oxygen sensors. Fuel pump, intake manifold gaskets twice (now with "updated" steel gaskets), throttle body gasket/seal, injector o-rings (upper and lower). Tested all coils for strong spark. Smoke tested for vac leaks along with propane. It has never failed to start or even had a long start and has never died/stalled. I'm just kinda at a loss at this point. Any help will be appreciated and possibly considered. Thanks
    • By Alex Warner
      Hello!
       
      I have taken my truck to a couple shops but no one can seem to find what wrong with it.
       
      When I come to a stop, my truck acts like it wants to stall out. It doesn't happen all the time but it is becoming more frequent. When stopping, the rpms die, all my gauges drop to zero and all my warning lights flash at me and turn back off. I don't have a check engine light on and when my truck is scanned, there are no codes that come up. 
       
      I have been told that it is possibly bad torque converter solenoids but I have a weird feeling that I might have some electrical gremlins somewhere. 
       
      There have been times where I am driving down the road and I go to make sure my windows are rolled up and the gauges due while rolling and my electrics cut out for a second and come back on. 
       
      There was also once where a truck pulled out down the road from me so I applied the brake to give them room and my truck downshifted hard and jumped to 3500 rpm and felt incredibly sluggish to get back on gas and up to speed.
       
      Any help or any direction to a fix is greatly appreciated. Please help me find out what's wrong with my truck! Thank you!
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    234,392
    Total Topics
    2,492,934
    Total Posts
  • Member Statistics

    256,726
    Total Members
    8,960
    Most Online
    Alex Brooks
    Newest Member
    Alex Brooks
    Joined
  • Who's Online   9 Members, 0 Anonymous, 1,961 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.