Jump to content

Philipgonzales3

Have you had any "issues" with your 2019 Chevy/GMC?

Have you had any mechanical or electrical issues with your 2019 Chevy/GMC?  

95 members have voted

  1. 1. Have you had any mechanical or electrical issues with your 2019 Chevy/GMC?

    • Yes
      25
    • No
      46


Recommended Posts

I want to guage how many people have had issues and how many have been worry free.  By issues I mean serious enough to take it to the dealer.  You can use your own judgement on determining if it is an issue or not.  

Share this post


Link to post
Share on other sites

A lot of pesky little issues.. none requiring a trip to the dealership.

 

Climate control showing "off" when I actually have the fans running. I'd turn it off then back on, but the "off" would still blink without showing the fan speed. A fix would be to turn it off then back on, it may or may not do it again.

 

Fish-eye while reversing, but a simple fix was to wait for about five seconds then shift in reverse.

 

And the loud unsettling thunk whenever I shift to Drive after starting it up.. like above, a simple five seconds, maybe ten seconds then it'll be smoother.

 

I am still not used to this, none of my Ford F-150's had that, both were flawless. I know it varies among owners with some F-150's drinking oil. I had the older Coyote 5.0 and it was rock solid. The engine in the Chevrolet seems to be solid too.

  • Like 2

Share this post


Link to post
Share on other sites

Now this is a Topic i would be curious to browse through over on the 2019/2020 RAM 1500 Forums!  LOL

  • Haha 3

Share this post


Link to post
Share on other sites

I'm in the process of lemon lawing mine...

  • Confused 1
  • Sad 2

Share this post


Link to post
Share on other sites
5 minutes ago, MDSilveradoGuy said:

I'm in the process of lemon lawing mine...

:(

  • Confused 1

Share this post


Link to post
Share on other sites
24 minutes ago, MDSilveradoGuy said:

I'm in the process of lemon lawing mine...

Can you go into detail why you are lemon lawing?

 

I have 2 small issues that goes unnoticed, 

First, when on Bluetooth, the audio's highs come and go, sounds like the tweeters are not connected properly. When i plug in my iphone then i have no problem. I am running an apple watch so two bluetooths connected might be the culprit. 

 

Second, the dash "touching" the door is not properly seated/ warped. i only see it when getting in the truck. 

Share this post


Link to post
Share on other sites
35 minutes ago, MDSilveradoGuy said:

I'm in the process of lemon lawing mine...

 

I've read some of your posts.  I always like to stay informed but hard for me to do so and not be paranoid.  I think it comes down to luck but trying to get an idea on the percentage of people with issues just for curiosity.  I believe a large number of owners don't have any issues but maybe I am wrong and I know if I had the issues you or others have I wouldn't care what the percents were.  I would just want the problem fixed, whether that means switching brands or what not.  

 

The only positive is it seems Chevy dealers give loaners.  I already had 1 loaner to get some goodies installed on my truck.  From what I understand my old Ford dealers did not provide a loaner no matter what unless you bought the high end extended warranty.  

  • Like 1

Share this post


Link to post
Share on other sites

I’ve never been paranoid myself and would like to think I am understanding. I knew I was buying a first year truck, with a first year powertrain and while inconvenient - expected some minor issues. 

 

What I did not expect was a total damn meltdown that left everyone scratching their heads. The powertrain is amazing - the wiring to it, not so much. 

 

The whole thing just makes me sad. I’m not pissed, I’m sad. 

Share this post


Link to post
Share on other sites
17 minutes ago, BlancoSilverado said:

Can you go into detail why you are lemon lawing?

 

It’s long but the whole story is there. 

Share this post


Link to post
Share on other sites

I have said it before and will say it again.

Automakers do not spend enough time testing new releases.

As a result unfortunately, some very early first year owners suffer from it.

I do not think anyone would buy a brand new car, truck or SUV knowing they are a guinea pig for engineers and Technicians during that first year

until most of the bugs are worked out.

You have the new 2.7L Turbo. I suspect there will be some problems with the new 3.0 Diesel as well.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Nothing huge.

 

4WD warning light came on, truck was stuck in 4WD and didn't disengage when I was on a trail. Turned it off, restarted and went away, but the parking brake lamp illuminated and would set itself anytime I put the truck in park. Dealer did a relearn and it has been fine ever since. 

 

8speed at first kicked at low speeds, but that's mostly gone away as I have almost 8k on mine.

 

I use the truck as it was intended, lots of off-roading and some hauling. I couldn't be more happy with it.

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, MDSilveradoGuy said:

I’ve never been paranoid myself and would like to think I am understanding. I knew I was buying a first year truck, with a first year powertrain and while inconvenient - expected some minor issues. 

 

What I did not expect was a total damn meltdown that left everyone scratching their heads. The powertrain is amazing - the wiring to it, not so much. 

 

The whole thing just makes me sad. I’m not pissed, I’m sad. 

If I were you I would be both.  To be honest I am sad for you even though it isn't my truck.  I had the first Android phone, the T-mobile G1.  Phone sucked and since then I have always believed to never by the first version of anything.  I do a lot of reading about all types of topics and that always seems to be the consensus regardless of the product.  I waited to get a truck for years, at least the last  5 years I have wanted one (I am 29 if that matters).  

 

Anyway, yeah I couldn't help myself here.  Hoping for smooth sailing but either way like to read up on all the issues, mods, configurations, etc, etc... 

 

I'm only at about 800 miles myself, but I know others have had issues pretty early on.  Anyway, be sure to keep us updated on how the lemon law thing works.  I've never had a lemon yet (fingers crossed) so would be curious to know how everyone's issues are resolved or what not.  

Share this post


Link to post
Share on other sites
Posted (edited)

A lot of the issues are just bugs that I haven’t bothered seeing a dealer for, and/ or things that corrected themselves. The rampant “trailer disconnected” error did send me to the shop this past winter, but it has since been corrected by GM. Overall for a first year product I think it’s been good. And I’m a fairly early build, 10/2019. Whoops, meant 2018!

Edited by OnTheReel
  • Like 2

Share this post


Link to post
Share on other sites

Recurring fail to start issue with 2019 Denali XL. We’ve left it at the dealer and have a 20 model build date in about two weeks


Sent from my iPhone using Tapatalk Pro

  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.