Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Couple more issues with 98 Yukon


Recommended Posts

I don’t know if you all remember me or not. About a month ago I posted about my Yukon misfiring terribly. I fixed that thanks to your expertise and now I have a couple other small issues. 

 

Number 1. I keep getting a P0430 code. I’m pretty sure the right side cat is bad. When reading the O2 sensors. The graph shows identical readings for the upstream and downstream sensors. I’m pretty much resigned to the idea that I’ll have to replace the cats, and found a new set for a decent price. Still I was wondering if any of you could recommend a good set. I can’t weld, so I’ll need to buy the whole assembly. I (think I) have some time on this because I don’t need another emissions test for over a year, but correct me if I’m wrong and if this problem is actually more urgent than I think it is.  

 

Second, and more importantly, I’ve got a squeaky wheel. I tried to diagnose it, by jacking each wheel off the ground and turning it manually, but nothing happened. I checked the CV joints and brake pads in the front, but after a really bad experience when I was younger I won’t mess with drum brakes, so I don’t know if something is up with one of the rear drums, and the rear axle doesn’t have CV joints. The noise seems to come from the front driver’s side wheel. So, if the CV joints and brakes seem fine does that mean the bearings are going bad? Is replacing them possible without an impact wrench and a hydraulic press? Could I just pack them and hope for the best? I’m going to do a little more trouble shooting and update the thread with any new pertinent info.

 

Thanks,

 

Eric

Link to comment
Share on other sites

I recently had the P0430 code.  Because I'm at 191k miles and still on the original O2 sensors, I went ahead and changed them out.  But, before I did, I found a very large exhaust leak where the cat Y-pipe bolts to the flange at the head of the tailpipe.  The flange is between the upstream and downstream O2 sensors.  I replaced the gasket and the O2 sensors and reset the code.  It's been 4 months and I've not seen that code again.  Either the leak or bad sensors (or both) can set the code, although I've always been told that 99% of the time the cats are bad.

 

The front bearings are part of a non-serviceable hub.  The usual indicator that they are going bad is having the ABS activate at low speed just before you come to a stop.  They usually don't squeak when bad, but rather make a grinding noise.  You can remove the wheel, caliper and rotor, then the big nut in the middle.  After that I think there's just 3 bolts attaching the hub.  No impact driver needed.  Remove the hub and grab the bearing.  Move it around and look for any play.  It should be tight and just spin.  If it's bad you'll need to replace the hub assembly.

You didn't say if the squeak is only during braking or not, or if it sounds like it's rotational.  In the front, the likely culprit are the brake pads.  If they're worn, the metal howler will make contact with the rotor and make all kinds of noise.  Or, the pads are producing harmonics and need to have anti-squeak stuff applied to them to make it stop.  There could be other causes but those are the most usual and most obvious.  In the rear, worn shoes can expose the rivets causing them to make contact with the drum.  Sometimes other components come loose and make contact with something they're not supposed to touch.  Pull the drum and make a visual inspection.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By romeactual
      Currently running Atturo Trail blade XTs - Nice looking tire, a bit loud and showing signs of what looks like dry rotting after 2 years.
       
      I want to get a new set of all terrains or hybrids but not looking for a mud tire on the stock 22" snowflakes. Leveled and running spacers.
       
      Open Country A/T III is my first choice, followed by the Cooper Discoverer Rugged Trek.
      Size wise, I would go for a 33x12.5x22 or a little smaller (285x45 r22).
       
      Any other options out there I should consider? Please post pics if you have a nice looking A/T tire setup on 22s.
       
      2019 sierra 1500 SLT

    • By RocknRollAttitude
      The Trail Boss right after installing the Wicked W903 20x10 wheels and Federal 33x12.5 tires.
    • By B33tl3
      Like new only a couple K on them. 
      Comes with OEM locking lug nuts
      I am in ****** Ga north of Atlanta. 
       
      Asking $1200 OBO
       
       

    • By Mitchell Jackson
      Wanting to get bigger tires on my truck, installing a lift kit as well.
       
      Can I stretch 285/55/r20's on 20x12 rims with -44 offset? 
       
      Has anyone does this? 
       
      Also will this effect my tire life any reviews would be awesome.
       
      (Leveling kit recommendations would be awesome as well)
    • By Im Here
      Snapchat-2110446941_1_1.mp4 I got Silverado 2018 Ls single cab with BF Ko2 tires factory size, gonna lift the front 2.5 inches , so , i intend on putting method wheels, but confused with the size of it.  
      What do u recommend? 
      Is the tires size ok with the 2.5inch lift? 
      Tire size 265/70R17
      By the way the front lift is Motofab.
      Hope i can get answers. 
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    240.7k
    Total Topics
    1.4m
    Total Posts
  • Member Statistics

    299,183
    Total Members
    8,960
    Most Online
    mikek3774
    Newest Member
    mikek3774
    Joined
  • Who's Online   10 Members, 0 Anonymous, 961 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.