Jump to content

Recommended Posts

 I have a 2001 Silverado 2500 HD, wondering if I had a body control module issue,  my heated seats don’t work, my driver side seat only worked half way i.e.  The lumbar support works but the lean and moving the seat functions do not,  along with my keyless entry not working but my power locks do work. Any ideas? 

79C56636-22FB-47CF-A72C-5BD2B3EA4480.jpeg

Share this post


Link to post
Share on other sites

I'm having similar issues. Did you get it resolved?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By 14AllTerrainSC
      See a lot of questions asked about this and not a lot of set info on the upgrade.  Hope this helps even anyone trying to set it up.
       
      **READ ALL INSTRUCTIONS AND WATCH ALL VIDEOS PRIOR TO ATTEMPTING PURCHASING OR INSTALLATION**
       
      Apple CarPlay / Android Auto functionality is not supported in any 2014-2015 (Many 2016) Silverado/Sierra’s. This is due to neither application being available from Google or Apple when these vehicles being built, therefore not an available option during these model years. The following instructions are designed to simplify the process as much as possible.
       
      Three things are required for this upgrade (ONE) Radio Module, (ONE) HMI Module, and (ONE) USB Hub 2016+.
       
      Search around for the modules, they are available for purchase from many different locations. EBay, totaled vehicles, junkyards, or other various websites to find them. AGAIN, if the part numbers are not listed below DO NOT purchase them.
       
       It is highly encouraged to not try and cut corners with purchasing part numbers of modules not listed as they cannot be flashed to work properly.
       
      **DISCONNECT THE BATTERY PRIOR TO INSTALLING FRESHLY UPDATED MODULES**
       
      TOOLS REQUIRED:
      Trim Removal tool
      10 mm Socket
      7 mm Socket
       
      PARTS REQUIRED
      USB HUB P/N 13519224 (BLACK) P/N 13509943 (WHITE)
       
      HMI Module
      USE ONE OF THE BELOW P/N’S IF YOUR TRUCK CAME FROM THE FACTORY WITH NAVIGATION. ONLY REQUIRED TO PURCHASE ONE P/N.
       
      84006103
      84048396
      84096817
      84156701
      81431943
      84296482
       
      USE ONE OF THE BELOW P/N’S IF YOUR TRUCK CAME FROM THE FACTORY WITHOUT NAVIGATION. ONLY REQUIRED TO PURCHASE ONE P/N.
       
      84096815
      84156699
      84131941
      84296480
      84004948
      84048398
      84131941
      84296480
       
      RADIO MODULE
       
      USE ONE OF THE BELOW P/N’S IF YOUR TRUCK CAME FROM THE FACTORY WITH BOSE. ONLY REQUIRED TO PURCHASE ONE P/N.
       
      84062073
      84293226
      13506371
      23402903
       
      USE ONE OF THE BELOW P/N’S IF YOUR TRUCK CAME FROM THE FACTORY WITHOUT BOSE. ONLY REQUIRED TO PURCHASE ONE P/N.
       
      13506387
      23402909
      84062056
      84293243
       
      Once acquiring the parts you can now send them to be flashed. These modules will be flashed to your VIN and will then be plug and play. Copy the link and follow the prompts.  
       
      http://www.whiteautoandmedia.com/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=98&category_id=44&option=com_virtuemart&Itemid=54
       
      If you have followed all the directions up and to this point, select yes for hardware match. You can chose if you would like the maps updated on your NAV if you so choose. You will be emailed your order number from WAMS, this is EXTREMELY IMPORTANT. You will be required to ship your parts either FedEx or UPS, they will not accept packages from USPS. You will need to write your order number on the box to ensure your order is properly handled. Turn around is approximately one week from shipment to return. ONLY ship your (ONE) Radio Module and (ONE) HMI Module. Maintain your USB Hub.
       
      Once you have received your parts from WAMS you can begin installation. Disconnect your battery prior to installation.
       
      To install the radio module watch https://www.youtube.com/watch?v=I2MYuuyqLrs. For the purpose of this install start the video at 1:00. Stop the video at 2:04, the radio module is visible with a green connector on the far left. Simply begin disconnecting all of the connectors plugged into the module, once all are removed you can slide the module out of the dash. It is retained only by the tension of the cables plugged into it. Replace with your new module, you can now continue the video and finish putting the dash back together. Stop the video at 4:10.
       
      To install the HMI Module watch https://www.youtube.com/watch?v=sFe2gwlOsD4. Stop the video at 2:00. The module being described behind the crossbar is what you are replacing. Remove all connectors, the module is retained with a plastic clip on top. Installing the module along with the glove box, is self explanatory.
       
      Take note of the plastic tabs on the sides of the USB Hub you are preparing to install. Those tabs can be depressed with a dental pick and gradually removed out of place. Once removed, disconnect the harness and reconnect. Installation is now complete. You can now reconnect your battery and start your vehicle. Initial start up might take a few seconds to initialize, and temperature defaulting to 32 degrees is normal. Android Auto and Apple CarPlay require hardwire connection, so to test functionality it needs to be connected to the newly installed USB hub.    
       
      MVI Inc (https://www.gm-navigation.com/) offers kits and other customization options if the above is not something you feel comfortable acquiring on your own.
       
      Hope this helps, should be pretty cut and dry. There might be other methods, but this was the cheapest I discovered. If you have any questions don’t hesitate to ask.


    • By nalewis
      I currently own a 2003 Silverado 1500 LS with the Z71 package. I have almsot 284k miles on it with the 5.3 vortec engine. I have almost had it a year and bought it with 273k. I know it has been taken care of because its very clean, with no sludge in the oil, as well as no metal shavings in the oil and transmission pan when I changed their gaskets/fluids. So far I have changed:
      - Rear diff gears
      - Knock sensors
      - Catalytic converters
      - Trans fluid and filter
      - Oil pan gasket
      - Intermediate steering shaft
      - A/C system
      - T-case fluid
      - Added a Spectre cold air intake
      - A few other minor things
      As of now I have a rear main seal leak, as well as a clunk. I have researched the clunk and have come to the conclusion that it is the famous GM slip yoke clunk, so I am not too worried. It it was the trans, I would have likely seen metal shavings in my trans fluid. I am likely going to be fixing my rear main seal leak in a few months. I do all this work myself so it's not too expensive to fix and I kind of enjoy working on it. Basically, I really like my truck and I would like to keep it, but I am wondering how long I should expect from the engine? I'm pretty positive the trans has been changed since it has such high mileage. Let me know what you all think.

    • By nalewis
      I currently own a 2003 Silverado 1500 LS with the Z71 package. I have almsot 284k miles on it with the 5.3 vortec engine. I have almost had it a year and bought it with 273k. I know it has been taken care of because its very clean, with no sludge in the oil, as well as no metal shavings in the oil and transmission pan when I changed their gaskets/fluids. So far I have changed:
      - Rear diff gears
      - All shocks
      - Knock sensors
      - Catalytic converters
      - Trans fluid and filter
      - Oil pan gasket
      - Intermediate steering shaft
      - A/C system
      - T-case fluid
      - Added a Spectre cold air intake
      - A few other minor things
      As of now I have a rear main seal leak, as well as a clunk. I have researched the clunk and have come to the conclusion that it is the famous GM slip yoke clunk, so I am not too worried. It it was the trans, I would have likely seen metal shavings in my trans fluid. I am likely going to be fixing my rear main seal leak in a few months. I do all this work myself so it's not too expensive to fix and I kind of enjoy working on it. Basically, I really like my truck and I would like to keep it, but I am wondering how long I should expect from the engine? I'm pretty positive the trans has been changed since it has such high mileage. Let me know what you all think.

    • By jayare90s
      On the 2016-18 Z71’s. Has anyone had trouble with the adhesive on the molding? Every time I look over at it, it’s popping out and noticeable. Im A little worried that it’s going to end up ripping off soon. I cleaned it up and used 3M double sided tape on it but looks like it keep wearing off for some reason. 

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    204,561
    Total Topics
    2,184,995
    Total Posts
  • Member Statistics

    173,782
    Total Members
    8,960
    Most Online
    David Iungerich
    Newest Member
    David Iungerich
    Joined
  • Who's Online   115 Members, 0 Anonymous, 993 Guests (See full list)

×

Important Information

By using this site, you agree to our Terms of Use.