Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Rob Mugs

Well crap... catastrophic engine failure?

Recommended Posts

 

Just under 2,500 miles ?

Edited by Rob Mugs

Share this post


Link to post
Share on other sites

Anyone that has had a spring break, this it?  Sounds worse to me

Share this post


Link to post
Share on other sites

no CEL?  Probably not.  That is GM's get out of jail free card majority of the time and it is completely intentional.  GM chooses to not incorporate this logic into their software to limp their vehicles through the warranty period.  Then bend you over.

Edited by 1997SierraSLT

Share this post


Link to post
Share on other sites
35 minutes ago, 1997SierraSLT said:

no CEL?  Probably not.  That is GM's get out of jail free card majority of the time and it is completely intentional.  GM chooses to not incorporate this logic into their software to limp their vehicles through the warranty period.  Then bend you over.

Does have a CEL but unfortunately, OnStar app shows nothing.  I'm guessing it's going to be a misfire code as it feels like it's running on 2 cylinders 

Share this post


Link to post
Share on other sites

I don’t think it’s a spring issue.  When one spring goes these direct injected engines, the engine will barely run or not run.  How well does the engine run?   Just throwing it out there, check the plug wires and make sure they’re all on tight.  Hopefully it’s not a lifter issue.  

Edited by SILVER SLED

Share this post


Link to post
Share on other sites

Kind of sounds like the 16 I had when it broke a push rod, no power, ran like crap (of course), and shook violently. 

 

At this point, get it as soon as you can.

Share this post


Link to post
Share on other sites

What's a sales guy going to do?

 

It's not his problem, he's not the mechanic working on it.

 

 

Share this post


Link to post
Share on other sites

Sounds like a new engine for you. 

 

That's why we buy'em with warranty.

Edited by redwngr

Share this post


Link to post
Share on other sites

And at this point, the truck is owned by the bank (or the OP) , not the dealership, salesperson, or GM.

Share this post


Link to post
Share on other sites
2 hours ago, CamGTP said:

What's a sales guy going to do?

 

It's not his problem, he's not the mechanic working on it.

 

 

Agreed.. it's not his problem.  He didn't design, engineer, or build the truck.  He just sold something he thought would be working.

 

@SILVER SLED, she barely can maintain idle.  CEL is on but OnStar says no issues.  I wasn't on it either;  I was at 50 mph and cruising when I felt what seemed like a flat tire at first.  Over a period of ~15 to 30 seconds it went from that to sounding like a lifter tick to a full-on bang sound.

 

Been a GM guy for 20+ years..... had two Fords with no issues.  This isn't leaving a good taste in my mouth

Share this post


Link to post
Share on other sites
7 hours ago, stevejones said:

Eff that.  2500 miles?  I'd be texting my sales guy telling him to come get this POS & bring me another truck to drive...

And he would tell you to stuff it.  Not his problem.

Share this post


Link to post
Share on other sites

If it's still driveable and safe to do so, I'd keep on driving it til she blows.  That way you're sure to get a new engine. ?

Share this post


Link to post
Share on other sites
6 hours ago, Steve-2019 said:

If it's still driveable and safe to do so, I'd keep on driving it til she blows.  That way you're sure to get a new engine. ?

Was driven less than 3/4 of a mile to get it somewhere safe to be stopped and then towed by dealer.  Will hopefully know more this week but what a shitty time to happen with the holidays and all 

Share this post


Link to post
Share on other sites

It’s probably a spring.  I’m kinda amazed how one bad spring will make these things run terrible, not stay running or not run at all.  

Edited by SILVER SLED

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.