Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

I purchased my 2020, 2500 Duramax in September. I ordered it with the all of the trailering features.
 

I also ordered an auxiliary camera to attach my travel trailer, which I installed in November. 

 

It worked great for the first two months.

 

Six weeks ago it stopped working completely. 
 

I tried every combination of plugging and unplugging, cleaning connectors, switching between the interior and exterior jack.  
 

Finally, I removed it from the trailer and took it to a Chevy dealer.

 

They let me plug it into one of their trucks to see if it was the camera or my truck that was the issue.

 

The camera did not work on their truck either.
 

Chevy sent me a replacement camera under warranty, which I received last week.

 

After installing it, it worked great for two days, then stopped.

 

Has anyone else had similar problems?  


 

Thank You

 

Link to post
Share on other sites

I'm not sure this will help with the above problem but I purchased a GM trailer camera about a month ago but have not had a chance to test it until today.  Temps have finally warmed enough to allow me to plug into the trailer and ensure the camera was  working.  It went well - the camera showed a light inside the camera lens as soon as it was plugged into the truck receptacle.  The camera view also showed on the infotainment screen inside the truck when I went to that view on the system.  I'll be running the cable to the back of the trailer and mounting the camera over the next few days.  Everything looks promising.

Edited by unit
Link to post
Share on other sites

It seems to me the GMC Brake guys are the same ones who designed this camera system as well. That is a shame because I am about to purchase the same camera for my new hauler.

Link to post
Share on other sites

Guys, here are a couple things to try.  The cameras do not like a hot hookup.  When hooking up your trailer, once you get your hitch lined up, shut the truck off and close the doors.  Hook up the trailer,  plug in 7 way, and finally hook up cameras.  Start the truck up, pump the brakes a couple of times, and then select your trailer profile or setup a new one.  

 

If you still have problems after following this, you may have a hardware issue.

 

#iworkforGM 

Link to post
Share on other sites
  • 3 weeks later...

I ordered the GM OEM trailer camera. I followed the  instructions an input all of the measurements only to receive a message that the trailer is too long. Anyone else having problems? 

Link to post
Share on other sites

There is a length limit but it will still work if you put the maximum length value in.  I believe the length limit is around 10 meters.  Convert that to inches and go down an inch at a time until a number works.

 

#iworkforGM 

Link to post
Share on other sites

I have the same problem. 2020 Denali HD... have 2 enclosed trailers, bought a camera for each trailer. My snowmobile trailer camera worked for the first season, an occasional issue, but a reboot would fix it.  Now, I have nothing but a black screen with an X in the upper right corner. I tried every fix, reboot, truck off... nothing works. I will try the other trailer to see if it the camera or the truck.

 

Edited by In2racn
Link to post
Share on other sites
  • 2 weeks later...
On 3/22/2021 at 2:41 PM, MTU Alum said:

There is a length limit but it will still work if you put the maximum length value in.  I believe the length limit is around 10 meters.  Convert that to inches and go down an inch at a time until a number works.

 

#iworkforGM 

How do I delete or reset the camera settings and start over?

Link to post
Share on other sites
On 4/8/2021 at 8:50 AM, MTU Alum said:

Either go into trailer profile and change one of the dimensions or delete trailer profile and start over.

 

#iworkforGM 

Can you be more specific? Where do I go to do this?

Link to post
Share on other sites
10 hours ago, Foldbak said:

Can you be more specific? Where do I go to do this?

Select trailer app through your infotainment screen.  Create a new profile or select an existing.  I believe the next step is selecting conventional, 5th wheel, gooseneck.  Transparent only works with conventional.  I believe next step is select trailer type.  I believe transparent only works with cargo, horse, and one other one.  The next step it will ask about transparent setup.  This is where you enter your seven dimensions.  Next step would be calibrate.  I'm doing this from memory so I may have missed a step.

 

#iworkforGM 

Edited by MTU Alum
Link to post
Share on other sites

The easiest way to change the trailer dimensions is to use the phone app if you have an OnStar subscription.  Alternatively you can press the pencil shown in the image below to go into trailer settings.  Trailer dimensions are available from there.

 

 

F09-trailer-app-trailers-2.jpg

Edited by unit
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By cansled
      Looking to add the Tire Pressure Sensors to each of the 4 wheels of my RV.  If anyone's truck came with these and you do not need them, please PM me
    • By ZeeDunny
      Just picked up a Denali Grille w/ camera and am wondering if anyone has done the install themselves and ran into any issues hooking up the camera? I’ve only seen a few videos online of the new body style sierra grille replacement but am unsure if the camera addition will give me any issues. All help appreciated!  
       
      Will be posting before and after photos as well??
    • By FuzzyNuggets
      I own a 2020 trail boss and it boggles my mind that GM did not offer a front facing camera on their off-road purpose TrailBoss! Not only would it be great for parking but even more important when approaching off road obstacles. Does anyone make or have installed a front facing OEM style camera that integrates with the RPO code IOS 7” screen? 
       
    • By aseibel
      Just picked up a 2021 Acadia on new years eve. It has the Denali technology package, but I would assume the backup camera is the same on all models. My wife has complained about the backup camera not displaying upon cold start, but it works later after re-starting. It has worked each time I drove it, I finally saw the black screen of death this AM.
       
      When we were shopping we considered a very low mileage 2020 Acadia Denali that was bought back due to camera/display problems. It had been fixed, but instead, we chose to get a new one in the wife's preferred color. So it seems that this may be a common problem.
       
      So, is there a TSB about this? Is there a known fix? Being under warranty, all I care about it getting it fixed with the least amount of inconvenience to us.
      I'd like to do my research before taking to the dealer, especially since it seems to work when the vehicle is warmed up. I don't want to waste my time if it is something the dealer won't be able to replicate without leaving it sit there overnight.
    • By Dean Fischbeck
      I drive a 2020 Sierra 3500HD Denali 4X4.  Used mainly for towing a 5th wheel.  We purchased the GM rear-view trailer camera and had the RV dealer install it.  It works fine, but this has happened twice (out of maybe 40 hitchups) . . .
       
      During the process of hitching up, everything works fine.  One of the last things we do is turn the engine off, plug the rear-view trailer camera in, and then restart the engine.  Cameras all work, we're good to go.  But then after we shift into gear, ALL the cameras go dead (except for the rear-view mirror).  We turn the truck off and restart . . . doesn't help.  We call our GMC salesman who helpfully suggests that we disconnect the battery, wait 15 seconds, and then reconnect so the system can reboot.  This works and we're off.  He also intimated that a software update from GM might fix the issue.  This has only happened during hitching up, never during an unhitched start-up.
       
      Today we took the truck to the GMC dealer for routine maintenance and the Service guy said he is unaware of a bulletin, notice, or rumor regarding camera failure.
       
      Has this happened to you?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    230,933
    Total Topics
    2,465,749
    Total Posts
  • Member Statistics

    231,132
    Total Members
    8,960
    Most Online
    Phillip gray
    Newest Member
    Phillip gray
    Joined
  • Who's Online   53 Members, 1 Anonymous, 3,087 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.