Jump to content

Recommended Posts

Getting service lights for traction control and stabiltack. During the d sa ne time I am getting speedometer gauge jumping and hard shifting on transmission which makes me think speed sensor faulting as well. What could be causing multiple sensors faulting at the same time...

Share this post


Link to post
Share on other sites

Proper cleaning of throttle body can't hurt,both happen at same time?

  • Thanks 1

Share this post


Link to post
Share on other sites

Yes it happens at the same time. Every time I make an appt to take it in the errors goes away and the truck acts like nothing ever happens. 

  • Haha 1

Share this post


Link to post
Share on other sites
On 7/22/2019 at 2:03 PM, Nettie said:

Getting service lights for traction control and stabiltack. During the d sa ne time I am getting speedometer gauge jumping and hard shifting on transmission which makes me think speed sensor faulting as well. What could be causing multiple sensors faulting at the same time...

 

How old is the battery?  Check the battery cables and grounds, thrice.  A bad cell in a battery can wreak on the electrical system and send one off in all kinds of false directions.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.