Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

 

 

Check out the video I posted on YouTube regarding the issue I am having... 2016 Silverado

 

The function buttons (Radio, Phone, Nav, Text) buttons at the top of the tech screen and the radio function buttons at the bottom of the screen disappear sometimes... Not all the time. And there is no specific duration they stay on or specific frequency they turn off. Sometimes they will be there for my entire commute, sometimes within seconds of turning on my truck they disappear, and sometimes it's within 5-10 mins. It's annoying as all hell. The buttons come back if I tap the screen but I figure they are supposed to be up there all the time and should be.

 

Brought my truck to the dealership for oil change, inspection etc... and had them look at. They said they reset the system and 10 mins down the road after leaving the buttons blinked out again.

 

Anyone else have this issue, know how to fix it, etc...?

Share this post


Link to post
Share on other sites

Hey man,

 

I am having the same issue and cannot find anything on it anywhere.

 

Did you every figure out what was wrong with it or the dealer?

 

Thanks!

Share this post


Link to post
Share on other sites

Our My Link goes back to the home screen every time you start the vehicle up. Also the steering wheel controls don't always work. You can scan up or down and then it goes back to the original station before you started scanning on the steering wheel.

 

Seems GM really needs to put some R&D time back into this thing. To many bugs it seems.

 

Going into the dealer to have the radio replaced. They said that is all that they can do. No updates are available. I keep checking ever few weeks. Going to get this taken care of if I can while still under warranty.

Share this post


Link to post
Share on other sites
On ‎10‎/‎09‎/‎2017 at 5:40 PM, Black02Silverado said:

Our My Link goes back to the home screen every time you start the vehicle up. Also the steering wheel controls don't always work. You can scan up or down and then it goes back to the original station before you started scanning on the steering wheel.

 

Seems GM really needs to put some R&D time back into this thing. To many bugs it seems.

 

Going into the dealer to have the radio replaced. They said that is all that they can do. No updates are available. I keep checking ever few weeks. Going to get this taken care of if I can while still under warranty.

Mine does the exact same thing, was told engineering was working on a problem but have no solution.  Latest problem I discovered is when using an IPOD half the artists and no playlists show up.  Worked just fine on the '14 I traded in.  This new one is complete junk.  Called the infotainment help line and filed a formal complaint.  If I hear nothing back I will be demanding a new head unit.  I bought a new truck not a used one.

Share this post


Link to post
Share on other sites

I didnt realize you could file a formal complaint.  I called them to and they said go to the dealer but I dont really want to go there just for a "reset"  It also could be the HMI module.  My truck just hit 6000 miles.  Makes no sense.

 

The only thing im afraid of is that it will make it worse,  everything is working but this is an extreme annoyance that shouldn't happen.  It just starting happening out of no where.

 

@aczr2k  where did you hear it was a problem they were working on?  from the dealer or the hot line?

 

Thanks!

Share this post


Link to post
Share on other sites

I heard from the dealer, I had it in about 2 weeks ago, I've only had the truck for a month.

 

Edited by aczr2k

Share this post


Link to post
Share on other sites

cool,  Keep me updated and I will do the same

 

Thanks man

Share this post


Link to post
Share on other sites
6 hours ago, aczr2k said:

Mine does the exact same thing, was told engineering was working on a problem but have no solution.  Latest problem I discovered is when using an IPOD half the artists and no playlists show up.  Worked just fine on the '14 I traded in.  This new one is complete junk.  Called the infotainment help line and filed a formal complaint.  If I hear nothing back I will be demanding a new head unit.  I bought a new truck not a used one.

As soon as work allows me to get away for a day, I'm taking it in for them to order a new head unit.  They told me over the phone that is the next step if and when I bring it in there isn't a software update.

Share this post


Link to post
Share on other sites

Anyone have any updates. I’m going to take my truck into the dealer in December. I’ve grown to deal with it but would really like it fixed

Share this post


Link to post
Share on other sites

Non here. Have not had a chance to take it in.

Share this post


Link to post
Share on other sites

Nothing new here, I was just at the dealer for my first oil change, I brought up the new head unit and they will not replace it since it is a known issue and they are working to resolve it.. At least that is what I was told.  I will be pushing harder if nothing is resolved in the next month.

Share this post


Link to post
Share on other sites

So weird guys. My truck just all of a sudden stopped doing it. And as soon as I click post it’s probably going to happen again. It’s been a few days. 

  • Like 1

Share this post


Link to post
Share on other sites

I am having the problem too but i have it using Pandora either through blue tooth or usb android auto,  the radio will show the menu for the tone settings, then go back to Pandora or it will jump to a radio station also on the information monitor on the dash that will also jump to Pandora menu, driving me insane.  I have a 2016 Colorado with 52000 miles on it. This started about 3 weeks ago, tool it to my dealer they charged me $120.00 said they downloaded new software but that didn't work. They also told me GM has nothing under issues with the My Link system which i thought was strange seeing hundreds of them on the web. I am thinking of just getting an aftermarket put in.  I know that i am done with GM, spent too much money on my truck to have it have these issues.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Yoda2
      I'm having big Infotainment System problems with my 2019 GMC Sierra Crew Cab Short Bed SLT +
      1- I can set the camera view I want to hole in memory for every time I put the vehicle in reverse and it holds so that I can see the back up camera and the front of the vehicle as it's going to swing.
      2- When I try to do this for when I put the car into drive all I can see is the front wheels where they touch the ground.
      If I bring up the camera menu I can select front view  BUT it will not hold this in memory.
      How can I make it so EVERY TIME I place the car in drive it will show the forward view.
      I have a narrow stone wall driveway and need to see the walls.
       
      3- Every time I start the truck the infotainment system comes on differently.
      Sometimes it will go straight to navigation set up, other times the audio page.
      It makes no difference which window I had up when the truck was turned off.
       
      4- Sometimes when I start up the vehicle I get a BLACK screen and I have to turn the truck off and restart several times to get the system to boot.
       
      I could go on and on about multiple problems with the Infotainment System.
      The dealer has updated the software twice already and still no joy.
       
      This is the worst example of automotive technology I've ever owned.
      I have a Genesis and an Acura and both have flawless computer systems.
    • By wforrest08
      If anybody figures out if the radio antenna on the new fugly HDs screws onto the K2 base (and receives signal) let me know. THANKS
    • By Rosshog
      Has anyone had trouble receving the account verification email when setting up a new user profile on the infotainment system?  I just bought a 2019 AT4 and tried creating a profile twice.  I've been able to create a profile and save settings, but have not received the account verification email it claims to have sent.  Any thoughts???
    • By Josh Dalrymple
      So I posted last week about an issue I've been having for quite some time. I've recently got a big up my butt about getting it take care of, and was messing around with it and discovered something new that may help with the diagnosis. 
       
      When I push the voice activation button, the system says "ready" then beeps. At this point, if I say nothing it will tell me some of the commands I can say. however if after the beep I say anything, it doesn't respond at all, and after about 30 seconds will say "goodbye" and hang up on me. Now, if I press the OnStar button which uses the same microphone, the OnStar rep can hear me just fine, so I know its not the microphone. 
       
      Any ideas?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    211,908
    Total Topics
    2,272,218
    Total Posts
  • Member Statistics

    185,307
    Total Members
    8,960
    Most Online
    Lance Lowery
    Newest Member
    Lance Lowery
    Joined
  • Who's Online   21 Members, 0 Anonymous, 657 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.