Jump to content

Noisy idle, clattering sound


Recommended Posts

My 5.3 2014 - Silverado makes a clattering noise while running/idling in park. Dealer affirmed "hearing it" saying may be "injector" noise. Advised to put some more miles on it and then bring it back in. They would compare it to another 2014 running/idling at that time. I know my 2010 was much quieter running/idling in park. Friend of mine (Ford guy) pointed the noise out to me when I stopped bye to "show off" my new ride. Embarrassed!!!!!

Edited by MotoMedic
Added Topic Tags
Link to comment
Share on other sites

My 2014 5.3 does sound different and louder than my son's 2010 5.3. I've read several times that this is due to the 2014 "Direct Injection" type fuel injection vs "Port Fuel Injection" of the previous years. Direct Injection is noisier.

Link to comment
Share on other sites

Mine sounds the same and I hate it!!! Honestly it's the one thing that drives me crazy every time I remote start and walk up to it or if I'm at a drive through. I think my 04 f350 diesel was smother. Someone mentioned using 93 octane would that have any impact?

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

My 2015 Denali 1500 has been in the shop for 8 days now. Symptoms. Flashing check engine light and traction stability light lit up. Truck losing power and sounding like it wanted to stall. Slight odour of burnt oil. Po300 code. First they could not figure it out. Had to wait three days for senior tech to come to work?!? Diagnosed as faulty fuel to injector. Waiting for snail mail to bring it in from Kentucky. I'm in northern British Columbia Canada. Hopefully that fixes it. Wtf

Link to comment
Share on other sites

Just bought a used 2014 scsb 1500 5.3 auto a couple weeks ago with 30,000 miles on it...if i had taken it thru a drive thru when i test drove it and heard the ticking of the injection pump i would not have bought it...the reason i traded my sierra crew in was because i was sick of the lifters ticking....never even noticed it on test drive but its driving me nuts..just bought a cat back system to make it a bit louder and mask it a bit...gonna put it on this weekend...im wondering if theres any way to insulate around it with sound deadener, or if i just have to crank up the radio...

Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.