Jump to content
Darmichar

Replacing 2.0 HMI module with 2.5 HMI module to add CarPlay/Android Auto to 2014-2015 Silverado

Recommended Posts

Dokus said if I paid to ship it to him, he would update and he would pay to ship it back, otherwise he would accept a return for refund.

Sent from my SM-G935P using Tapatalk

Share this post


Link to post
Share on other sites
18 minutes ago, woodyfriedt said:

Dokus said if I paid to ship it to him, he would update and he would pay to ship it back, otherwise he would accept a return for refund.

Sent from my SM-G935P using Tapatalk
 

Unfortunately that's your only option. He has the cheapest HMI's. Its kind of horseshit that he's making you pay return shipping for his mistake but in all honesty a flat rate small USPS box isn't very expensive (all the more reason for him to eat the cost of HIS mistake). 

 

I guess just live and learn? Good luck. 

 

 

Share this post


Link to post
Share on other sites
On 8/14/2018 at 7:04 PM, th3magpi3 said:

Yes and Yes. You can tell which one is the HMI because the exploded image shows a circle which represents the little fan at the top of the face of the HMI. 

 

And like I said, it doesn't have to be that exact part number. And it's because most of the people selling at are just selling them from wrecks that they don't specify a VIN reprogram.

 

Most all replacement parts require VIN programming to work, especially radio components. GM has had a "Theftlock" feature for their radios since the 90's. TIS2WEB and similar scanner tools can be used to unlock the radio modules. 

 

My seller specifically said to make sure my part number matches exactly with the one I bought (84278527). 

 

Here's another seller stating it may have to be reprogrammed.

 

image.thumb.png.8a8ab836740d2b5d106340665388ccd5.png

 

But like I said, a subscription to tis2web with a programmer or a trip to the dealership should take care of you. 

 

I will have my radio hopefully tomorrow and will update everyone on my experience. Stay tuned. 

I’m kinda stuck on the theft lock thing on my module been researching this for days now. The dealership wouldn’t clear it for me. So I’m trying the tis2web thing

Share this post


Link to post
Share on other sites
5 hours ago, rusty503 said:

I think I may have the solution to the no audio issue. It seems that Apple CarPlay has THREE volumes. One for Siri, one for Navigation and the other for music or maybe that was Phone. Let's start with Siri. Do something to make Siri reply to you. Try to make it something that will make her talk for awhile. WHILE she is talking, turn up the volume on the radio. It must be exactly when she is talking. If you don't get it just right, you will be changing the radio volume, not Siri. Another suggestion is to adjust the volume controls on your phone. In navigation try the same thing. I have also read that there is a setting in Apple Maps for audio. The settings if I remember are: No Volume, low, medium and loud. Someone else solved their issue by resetting the phone while connected to Carplay.

 

All this applies to Android Auto too.

 

The problems I have been reading in this thread are issues across the board with many other brands. It is issues with Carplay and Android Auto. NOT isolated to our trucks.

 

Do a web search about this and you will find pretty much the same. I used Siri no volume Carplay as my search terms. I don't have time right now to expound on this right now. Gotta run.

 

 

 

 

Have you upgraded the HMI in a 2014/15 K2xx and this worked?

This would be the solution for a vehicle that came stock with CP/AA. But we are attempting to upgrade older vehicles in an unconventional way and the rules no longer apply.

This works for my truck if using Bluetooth, USB (no CP), or on the old HMI. You can even see that the volume indicator is red rather than blue when making this adjustment. I wish this was the case with a swapped HMI, but while using CP/AA, it is not. It was one of the first things I attempted to do to fix the issue immediately after installing the new HMI.

Share this post


Link to post
Share on other sites
36 minutes ago, Jan Balt said:

I’m kinda stuck on the theft lock thing on my module been researching this for days now. The dealership wouldn’t clear it for me. So I’m trying the tis2web thing

Look though this thread and contact Chris White about programming it to your VIN. 

Share this post


Link to post
Share on other sites
Look though this thread and contact Chris White about programming it to your VIN. 
Or if you can wait a week or two I'll be offering the same service for a fraction of the price. If you need it ASAP I'd go with WAMS

Sent from my Pixel XL using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Like Roscopcoletrain, I haven't purchased anything yet for this, but wish I had a way of helping to figure this out.

  • Like 1

Share this post


Link to post
Share on other sites
Like Roscopcoletrain, I haven't purchased anything yet for this, but wish I had a way of helping to figure this out.
I'll be able to give you guys the exact part numbers to get or might even offer a complete package at an extremely discounted price. Like I said. Give me about 2 weeks. I'm just waiting for some final bits of hardware to come in and shipping isn't exactly lightning fast internationally.

Sent from my Pixel XL using Tapatalk

  • Like 2

Share this post


Link to post
Share on other sites

You must be getting the same setup I saw that cost 1000 euros!

Share this post


Link to post
Share on other sites
24 minutes ago, th3magpi3 said:

I'll be able to give you guys the exact part numbers to get or might even offer a complete package at an extremely discounted price. Like I said. Give me about 2 weeks. I'm just waiting for some final bits of hardware to come in and shipping isn't exactly lightning fast internationally.

Sent from my Pixel XL using Tapatalk
 

No rush!  I've survived this long without it.  I appreciate all the work you (and the others) are doing!

  • Like 1

Share this post


Link to post
Share on other sites
You must be getting the same setup I saw that cost 1000 euros!
Not buying a setup. As far as I know there isn't a pre-fabbed setup for doing this. But building a programming bench yourself can easily clear $3000-$4000. There are a lot of parts involved and many are high priced!

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites

So I'm shipping my HMI back to dokus to get updated. There really aren't any better deals out there, even with a second shipping charge. Wish me luck.

Sent from my SM-G935P using Tapatalk

Share this post


Link to post
Share on other sites
3 minutes ago, woodyfriedt said:

So I'm shipping my HMI back to dokus to get updated. There really aren't any better deals out there, even with a second shipping charge. Wish me luck.

Sent from my SM-G935P using Tapatalk
 

You're exactly right. Nobody comes close to his price. 

Share this post


Link to post
Share on other sites

So how is shipping going to be to get our module(s) to Canada and back? I had an e-mail out to Chris and haven't heard a peep yet.

Share this post


Link to post
Share on other sites
I noticed on that YouTube video the guy had the shop icon and I didn’t. Makes me wonder if the HMI would’ve been updated that Siri would’ve work after getting my radio updated. It did for the OP of the video. 

From what I found out about this...the shop icon came out in I believe 2018. If you opt for or get the shop icon, you have to buy the Pandora app. Prior to that, it was standard and free.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Mountain boy
      I downloaded Apple IOS 13 beta, the good news CarPlay for Spotify is much improved it now shows album covers, kind of cool. The bad news even with the 805 update and IOS 13 it still turns down the ringer to zero if you have adjust with buttons turned on. It also still changes the volume control. I now wonder if this is a GM problem or an Apple problem. I hope someone fixes it, I just almost missed a very important call. 
    • By Jacob Broadbent
      Hello All,
       
      I just bought 2017 sierra with the 7 inch touchscreen that advertisted as compatible with apple Carplay and Android auto. For whatever reason myself, the dealer, and the GM infotainment support can't figure out why it isn't working with apple. We can get the radio to work with Android Auto and connects right away as it should so I think that confirms that the USB port is not faulty and is correctly transferring data. I am using an Iphone 8 IOS ver 12.4 with the factory cable in good condition(no fraying of the cable) and have confirmed that the phone cable combination works in my girlfriends 2017 Chevy Cruze. We have also tried it with different cable combinations and different IPhones.
       
      Occasionally when an Iphone is plugged into it a message will appear on the radio saying "Playback Source is not available" and I have attached a picture of the message.
       
      Just a quick rundown of things I have tried to help with troubleshooting:
      Made sure that the Apple Carplay is on in the settings of the radio. Double checked that "press home for Siri is enabled" Double checked that the screen time settings weren't preventing carplay from working forgot phone in bluetooth settings and re-paired it. factory reset of radio tried different Iphones (IPhone 6, IPhone 8, IPhone XR, IPhone XS) tried different cables (and confirmed they all worked in the 2017 Chevy Cruze) Made sure the phones worked with Apple Carplay in the 2017 Cruze. tried all USB ports in the truck.  
      Appreciate all the help
       
      Jacob

    • By th3magpi3
      Hey everybody,
       
      Just wanted to check in again and let you all know about another exciting service we're happy to be offering... The Denali Cluster Upgrade!
       
      Many of you have requested this upgrade and I'm happy to report we have successfully completed the mod.

      If you're interested in this, you'll need to know a few things.

      Acquire a new or used GMC Denali cluster. This can be a Sierra or a Yukon cluster. (Please note: If you buy your cluster 2nd hand, DO NOT plug it into your vehicle.)
       
      Diesel/Gas: The cluster will need to match some aspects of your current vehicle. For example, if you have a gas spec vehicle you'll need to find a cluster that has an RPM gauge that goes to 6000rpm. If you have a diesel spec vehicle (2500, 3500) you'll need to find a cluster that has an RPM gauge that goes to 5000rpm. Both shown below.
       


      MPH/KPH: We can do BOTH USA and Metric market clusters. If you live in the USA, you'll want to get a cluster that has a speedometer that goes up to 140. If you live in a metric country, you'll want a cluster that goes to 200. Both options shown below.
       

       
      COLOR: If you have a GMC and you want to keep your RED color theme, you'll want to find a 2016 GMC Denali cluster. If you have a Silverado, have done a blue conversion, or have upgraded your HMI to the newer blue theme and you're looking for a BLUE gauge theme, you'll want a 2017-2018 Denali cluster.
       
      Android Auto/Carplay: For all of you Android Auto users wanting the use of your volume and track selection flippers back, this fixes it!!! once installed you'll once again have access to your flippers. This also allows for the long press of the voice button on the steering wheel to activate Google Assistant as well as Siri for Apple Carplay.
       
      Year Matching: There has been a lot of talk that all modules that are installed into the vehicle need to be of the same year. After extensive testing we have found this to be mainly false. As long as the modules are of the same generation you should be A-OK for the install. That means if you have a 2.0 HMI vehicle (2014-2015) you can use a 2014-2015 Denali cluster. If you have a vehicle with a 2.5 HMI (Carplay Enabled, 2016-2018) you can use any 2016-2018 cluster so long as it matches your vehicle specs as mentioned above. And if you have a 2014-2015 and would like to upgrade to a blue themed cluster while adding Android Auto / Carplay, we are more than happy to facilitate the upgrade all at once.

      Please reach out to me if you have any questions or are interested in getting this mod done to your own vehicle. Thanks for watching and enjoy the demo.
       
       
    • By ejdziurka
      Has anyone recently had issues with AndroidAuto not connected to their phone?  I've tried three different USB cables (all which charge the phone), reinstalled AA and removed all Bluetooth connections and reconnected the phone.  I suspect AA recently updated and now we are waiting on GM to update the infotainment system. When I touch AA on the screen it says, please connect a phone with AA app installed.  2019 Silverado RST with 8 inch infotainment, connecting a Samsung S8 with AA version 4.4.592344.  Yes, it had been working before, and one of the cables I tried was the one it previously functioned on.  
    • By pschne1
      First time poster. Have a 19 Trail Boss LT and when connected to CarPlay get a notice that says “access to contacts limited” but I can see my contacts behind the notice.  Then randomly it will work and I have access to my contacts.  I have attached a picture of what I see. Anyone else experienced this?  I have used multiple cables and it occurs on different phones. 

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    209,492
    Total Topics
    2,245,582
    Total Posts
  • Member Statistics

    179,094
    Total Members
    8,960
    Most Online
    Davis85
    Newest Member
    Davis85
    Joined
  • Who's Online   129 Members, 1 Anonymous, 3,086 Guests (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.