Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

GM 8 Speed Transmission. On the new GM 1500 Trucks


Recommended Posts

Hello Everyone. 

 

I had a question in regards to GM's 8 Speed Transmission. I'm looking into buy a Chevy Silverado, with the RST package. I've notice that package comes with the 8 speed transmission. However, I have look up online, as well as on here, and I've notice people having a lot of problems with that transmission. I also heard that they have done a fix with that transmission. My question is has any one bought the new body style Chevy truck with the 8 speed transmission and have  had any problems with it? Did they actually fix it? What are your thoughts? I'm also looking at other packages as well without this transmission too. 

 

Thanks! 

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

I have a 2019 w/ 5.3 Z71 package.  8500 mi to date and no issues with transmission. Only thing I see is there is no transmission dipstick to check the fluid.  I was advised that that is a dealer only check....

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

How does it compare to Ford's 10-speed?  I talked to one Ford guy and he said that his sometimes has to sit there trying to hunt round trying to find the best gear.  He said sometimes it's annoying.  The last time I ever owned anything with an 8-speed was in an Audi A4 and that thing ran sweet, but I've never had any trucks with an 8-speed yet.  All the GM vehicle's I've ever owned either had 4-speed auto's or 6-speed manual's.

Link to comment
Share on other sites

I went from an 02 Silverado 1500 4.8 4x4 4 spd auto to a 2020 LTZ 1500 4x4 5.3 8 spd. This transmission is a dream. Smooth yet firm, very responsive, and very fuel efficient package. I was a bit hesitant about the 8 spd after all the forums I read but realized that there was a huge majority of 8 spd transmission owners who were completely satisfied. I am now 1 of them and you most likely would be also.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Just check for leaks or other issues.  Look how Ford has come out with those 2020 Explorers and lots of people are having transmission leaks.  Something about the valve bodies messed up or something.  That's why I never like buying the first year of any vehicle.  Early adopters always get penalized.  I like buying things that are tried and true.

 

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

2019 Sierra SLE (new Gen.) with 9k miles on it. 

Had nothing but pain with their 8 speed tranny.

Had the tranny fluid replaced, flushed and the shuddering/jerking issue is still there.

Brought to service a 5th time, looks like the torque-converter is the next thing they'll be replacing.

Somehow I doubt that will fix the problem...

Link to comment
Share on other sites

  • 2 weeks later...

My truck has the 19' 1500 4x4 5.3L with the 8speed and i constantly have a hard catch, notchy feeling shift between first and second at low speeds at various times.  Like it doesn't catch and then lurches forward or back (if in reverse).  Taken it the dealer several times and because the techs can't 'replicate it' I'm SOL.

Edited by Ecochef
Link to comment
Share on other sites

On 12/10/2020 at 11:05 AM, Ecochef said:

My truck has the 19' 1500 4x4 5.3L with the 8speed and i constantly have a hard catch, notchy feeling shift between first and second at low speeds at various times.  Like it doesn't catch and then lurches forward or back (if in reverse).  Taken it the dealer several times and because the techs can't 'replicate it' I'm SOL.

Thats the biggest 8 Speed issue on the 2019+ trucks. New fluid helps, there is a service bulletin but they have to keep the truck over night. 

Im trading my 8 speed for a 10 speed. 

Link to comment
Share on other sites

  • 1 month later...
On 12/15/2020 at 3:32 PM, TeamSaris said:

Thats the biggest 8 Speed issue on the 2019+ trucks. New fluid helps, there is a service bulletin but they have to keep the truck over night. 

Im trading my 8 speed for a 10 speed. 

I traded my truck in for a 21 with the 6.2L with the 10spd.  So far so good.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Scotty Harder
      So around this time of year last year I changed my brakes and my rotors and was going to replace my front bearings as well. My 08 is a Michigan truck so it’s got a plethora of rust accumulated. One of caliper bolts had seized so I completed what I could with the brakes and headed home to figure the best attack for a seized rusted bolt with thread lock. Anyways that bolt was a ******, so I went to my brother cause he had an air compressor and thought we’d try that. Needless to say the bolt one, so my brother put the wheel back together but before he put the caliper back in place over the rotor he decided to decompress the spring?. Why? I have zero idea thought it was pointless for him to do that Considering I had to do it to change the springs. So I start to head back home just worried about getting this bolt out so I can change my bearing. So as I start to leave I don’t notice anything out of place until I get down the road and my brake pedal goes to the floor. It made no sense, I couldn’t figure out what happened in the 30 minutes I was there; that would take my brakes from having good pressure to having none.  Then not long after that my fuel pump goes. Old Murphy’s law coming in clutch for me! So I get the fuel pump swapped get the caliper freed so I could replace my bearing. Then go to bleed my brakes and I can’t get any of my brake pedal back. I have abs so I I went out and bought a scan tool cause I heard bleeding brakes with an abs system without the scan tool is difficult and is more than likely the reason my brakes still go to the floor. So I do everything the device tells me to. There’s no change, except now I can’t shift it out of park to even attempt to check if there’s at least some pressure. I’ve been battling these brakes so at least the last half of 2021 my family is telling me to just sell it for whatever. Honestly I don’t want to sell it I rather enjoy having it and am not ready to let it go. Any help or advice would be so appreciated!



    • By austin jez
      Hello all. I have a 2013 silverado w/5.3l flex vin 7. Basically has rough idle in park and drive. Very poor acceleration. Almost seems to bog down when trying to accelerate. It will occasionally surge and for just a split second I can feel a bit of power.  Also doesn't want to downshift when I lean on the gas pretty heavy. I've got to do near floor it to get it to down ****** and when it does it will drop down 2 gears a lot of the time. No engine light and it won't set any codes. Showed 0 misfires on all cylinders. Long Fuel trims usually in single digits negs. Fuel pressure 43-46psi at idle and highway. I've replaced throttle position sensor, Accelerator pedal position sensor, manifold pressure sensor, mass air sensor, plugs, coolant temp sensor, oxygen sensors. Fuel pump, intake manifold gaskets twice (now with "updated" steel gaskets), throttle body gasket/seal, injector o-rings (upper and lower). Tested all coils for strong spark. Smoke tested for vac leaks along with propane. It has never failed to start or even had a long start and has never died/stalled. I'm just kinda at a loss at this point. Any help will be appreciated and possibly considered. Thanks
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    235.3k
    Total Topics
    1.4m
    Total Posts
  • Member Statistics

    263,282
    Total Members
    8,960
    Most Online
    aquezada
    Newest Member
    aquezada
    Joined


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.